Bug 1124021 - Slow performance, lots of reruns during "yum update" runs
Summary: Slow performance, lots of reruns during "yum update" runs
Keywords:
Status: CLOSED DUPLICATE of bug 1052173
Alias: None
Product: Fedora
Classification: Fedora
Component: shared-mime-info
Version: 20
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 20:20 UTC by matti aarnio
Modified: 2014-07-30 01:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 01:24:48 UTC


Attachments (Terms of Use)

Description matti aarnio 2014-07-28 20:20:58 UTC
Description of problem:
  Installing large update which delivers updates to the MIME INFO database
  runs this program multiple times during the "cleanup" phase -- when one 
  execution would be enough.


Version-Release number of selected component (if applicable):
  shared-mime-info-1.2-7.fc20.x86_64


How reproducible:
  Every time KDE or similar system library is updated
  Every module seem to want to run this at cleanup phase.

Additional info:
  Single run of the  /bin/update-mime-database  program takes
  quite a lot of time -- order of minutes -- and it is run multiple
  times during the update.

A possible way to handle this could be similar to how YUM watches the RPM database, and is able to note to the admin that "something has changed in
the database without yum being in action." (Whatever that text was.)
Read source files, read destination directories, compare time stamps -- if source has more recent modifications, then do the actual update.  (Plus detail of how it can detect removal of source files..)

Comment 1 Rex Dieter 2014-07-30 01:24:48 UTC
See bug #1052173

Which includes a workaround, otherwise, the optmization to run the scriptlet only once per transaction will land only for fedora 21 (and newer)

*** This bug has been marked as a duplicate of bug 1052173 ***


Note You need to log in before you can comment on or make changes to this bug.