Bug 1124029 - JON Server Restart via Plugin Service Restart Results In Exception
Summary: JON Server Restart via Plugin Service Restart Results In Exception
Keywords:
Status: CLOSED DUPLICATE of bug 1032039
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER04
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 20:48 UTC by Matt Mahoney
Modified: 2014-09-17 16:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-17 16:34:45 UTC
Type: Bug


Attachments (Terms of Use)
service.log (484.85 KB, text/plain)
2014-07-28 20:48 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2014-07-28 20:48:46 UTC
Created attachment 921929 [details]
service.log

Description of problem:
When restarting the EAP Service, the following exception occured:

16:29:56,341 ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
        at org.jboss.as.server.ServerService.boot(ServerService.java:308) [jboss-as-server-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
        at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:188) [jboss-as-controller-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]
Caused by: java.io.FileNotFoundException: /home/hudson/jon-server-3.2.0.GA/jbossas/standalone/configuration/standalone.xml (No such file or directory)
        at java.io.FileInputStream.open(Native Method) [rt.jar:1.7.0_45]
        at java.io.FileInputStream.<init>(FileInputStream.java:146) [rt.jar:1.7.0_45]
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:129) [jboss-as-controller-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]

Version-Release number of selected component (if applicable):
EAP6 Plugin Patch 01

How reproducible:


Steps to Reproduce:
1. Schedule an EAP Service "Restart" Operation
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Stefan Negrea 2014-09-05 21:00:14 UTC
Update the title of the bug to be less confusing. This is a problem limited to the JON server as per description.

The restart code needs to be fixed to use the correct configuration file.

Comment 5 Thomas Segismont 2014-09-17 16:34:45 UTC

*** This bug has been marked as a duplicate of bug 1032039 ***


Note You need to log in before you can comment on or make changes to this bug.