Bug 1124067 - Screen backlight not adjustable on Dell XPS 13 with 3.15.6-200 kernel
Summary: Screen backlight not adjustable on Dell XPS 13 with 3.15.6-200 kernel
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 22:27 UTC by Rudi Plesch
Modified: 2014-08-27 05:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-27 05:09:08 UTC


Attachments (Terms of Use)

Description Rudi Plesch 2014-07-28 22:27:24 UTC
Description of problem:
The backlight on my Dell XPS13 cannot be dimmed. I've tried various boot flags and BIOS setting with no luck. In every case xblacklight stops with "No displays have backlight property.

Version-Release number of selected component (if applicable):
3.15.6-200 kernel

How reproducible:
100% reproducible

Steps to Reproduce:
1. Boot with your choice of BIOS settings and kernel flags
2. Attempt to change the backlight with hotkeys or by echo 15 > sys/class/backlight/dell_backlight/brightness

Actual results:
Backlight remains unchaged

Expected results:

Backlight changes.

Additional info:

With regular boot flags:
    /sys/class/backlight is empty
    /sys/module/video/parameters/use_native_backlight is -1
        booting with video.use_native_backlight=1 did not change problem
    /sys/module/video/parameters/brightness_switch_enabled is n
        echo Y > there doesn't change anything
    pressing hotkeys does nothing

Booting with acpi_backlight=vendor populates /sys/class/backlight, and adding video.use_use_native_backlight=1 makes /sys/module/video/parameters/use_native_backlight 1. In either case the XFCE animations appear and /sys/class/backlight/dell_backlight/brightness changes when using hotkeys, but the backlight does not change.

I've tried this with both "Load Legacy Option Rom" enabled and disabled in BIOS. The behaviour doesn't change. There is another option, "Boot List Option", but this gives a "no operating system found", when I try to boot with it set to "Legacy".

I've read that this worked in previous kernel versions, so this seems like a regression. Thanks in advance for any help. Let me know if I need to give more information.

Comment 1 Rudi Plesch 2014-08-27 05:08:26 UTC
I resolved this by reinstalling. I added a new boot option according to the instructions here https://bugs.launchpad.net/dell-sputnik/+bug/1167617 in comment 3 instead of holding down shift in Windows reboot and selecting to boot from the flash drive.


Note You need to log in before you can comment on or make changes to this bug.