Bug 1124091 - [DOCS] BPM Suite Weblogic Installation and Configuration Guide
Summary: [DOCS] BPM Suite Weblogic Installation and Configuration Guide
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Documentation
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER2
: 6.1.0
Assignee: Dan Macpherson
QA Contact: Radovan Synek
Linda Snyder
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 00:36 UTC by Vikram Goyal
Modified: 2016-10-14 14:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-29 02:59:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Vikram Goyal 2014-07-29 00:36:20 UTC
Similar to the Websphere Installation & Configuration Guide, create a Weblogic Installation & Configuration Guide for 6.1 release based on the 6.1 PRD item: https://issues.jboss.org/browse/BPMSPL-64

Comment 2 Vikram Goyal 2014-10-24 03:38:57 UTC
DR4 BPMS release deployable for Weblogic: 

http://dev138.mw.lab.eng.bos.redhat.com/candidate/bpms-6.1.0-DR4/jboss-bpms-6.1.0.redhat-3-deployable-wls.zip

Comment 3 Dan Macpherson 2014-10-29 03:32:07 UTC
So I tried testing out the upstream procedure and ran into a couple of blockers.

Here's my notes:

* So the main issue is with deploying the application. I seem to be getting the following errors when creating tables:

<Oct 29, 2014 1:14:29 PM EST> <Warning> <Health> <BEA-310003> <Free memory in the server is 4,014,008 bytes. There is danger of receiving an OutOfMemoryError.> 
[29/10/14 01:17:30:030 EST] ERROR hbm2ddl.SchemaUpdate: HHH000388: Unsuccessful: create table Attachment ([list of field]) ENGINE=InnoDB
[29/10/14 01:17:30:030 EST] ERROR hbm2ddl.SchemaUpdate: ORA-00907: missing right parenthesis
[29/10/14 01:17:30:030 EST] ERROR hbm2ddl.SchemaUpdate: HHH000388: Unsuccessful: create table AuditTaskImpl ([list of field]) ENGINE=InnoDB
[29/10/14 01:17:30:030 EST] ERROR hbm2ddl.SchemaUpdate: ORA-00907: missing right parenthesis

It seems to be a lot of missing right parenthesis errors that are stopping me from deploying. Any idea how I can rectify/workaround these issues.

* There's a step in the Create JMS Queues that seems to be missing:
  - Choose the bus name
  - Choose Create Service Bus Integration Destination, follow the wizard and select the newly created queue name

I couldn't find buses or options to create them. Any idea where I can go to find these? (Might be for an older version; I'm using 12c)

* A blocker that I managed to fix: When I originally tried deploying I got an error regarding the JNDI names for the Connection Factories. It the upstream doc, it's...

jms/conn/KIE.RESPONSE.ALL

for the error log reported it was looking for:

jms/cf/KIE.RESPONSE.ALL

After I changed it, it started working (until I hit the missing parenthesis error)

Just to give some testing specs:
* I'm testing it using WebLogic 12c on a local VM (using libvirt)
* Data Source is an Oracle DB running on a separate local VM (also using libvirt)
* OS for both VMs is RHEL 6.5

Any advice here would be most appreciated.

Comment 6 Radovan Synek 2014-10-30 10:09:44 UTC
Dan,
just a guess - did you change hibernate dialect in WEB-INF/classes/META-INF/persistence.xml of business central before deploying it? By default there is MySQL dialect and you said you used Oracle DB.

Comment 7 Maciej Swiderski 2014-10-30 10:28:59 UTC
As Radek mentioned, you'll need to adjust the hibernate dialect to the correct one for your data base.

Then ensure you have the correct memory settings to avoid out of memory. When looking at the link to docs given by Vikram it does not refer to any bus setup (bus is WebSPhere specific). For Weblogic you need to setup JMS modules.

Comment 8 Radovan Synek 2014-10-30 10:37:51 UTC
Maciej, 

I think I've found incorrect information in instructions [1], looking into weblogic-ejb-jar.xml, there are separate connection factories for each queue, although in instructions there is mentioned only KIE.INPUT conn. factory.

[1] https://github.com/droolsjbpm/kie-wb-distributions/tree/master/kie-wb/kie-wb-distribution-wars/src/main/weblogic12

Comment 9 Maciej Swiderski 2014-10-30 10:40:56 UTC
good catch Radek, must have missed that will update read me file for that.

Comment 10 Maciej Swiderski 2014-11-04 17:10:37 UTC
updated community instruction for web logic about jms resources

kie-wb-distributions
master:
https://github.com/droolsjbpm/kie-wb-distributions/commit/9d36b39787ed85ca62f404d79c0c6e55a57f3098

6.2.x:
https://github.com/droolsjbpm/kie-wb-distributions/commit/ce690e023b31efce9e54257109ab247e417b14c7

Comment 11 Dan Macpherson 2014-11-07 05:42:13 UTC
Ran into the same exception as BRMS:

https://bugzilla.redhat.com/show_bug.cgi?id=1124091

Comment 13 Radovan Synek 2015-03-16 13:23:50 UTC
Dan and Vikram,

thanks for the documentation, please see my comments below:

1.1
> Red Hat JBoss BPM Suite for Oracle WebLogic Server is provided as two deployable web > application archives: business-cental.war and dashbuilder.war. 
There is a typo, should be "business-central.war", again, as for BRMS, there is missing note of application "kie-server.war".

> Before you proceed, make sure you have root access to the server 
I don't think root access is necessary, just an access to the account WebLogic runs in should be sufficient.

2.2 - entire chapter is obsolete, as WebLogic deployable bits are now (and will be) distributed as exploded WARs

3.1
Missing property kie.server.jms.queues.response, that does basically the same thing as kie.services.jms.queues.response, but is used by kie-server.

3.4
> JNDI Name - Set to jdbc/dashbuilder.
Dashbuilder should share DB schema with Business Central, when deployed together, it should use the same datasource.

3.5, Create JMS Connection Factories 
I see a formatting issue:
> KIE.SESSION - For sending messages to the process engine. The default value is jms/cf/KIE.SESSION. 
has got the ending dot on separate line.

4.2
I can't see a reason in steps 1 to 4, as this part of configuration has been already covered by chapter 3

Additional notes
There is a reference to Section 2.2, Section 2.2, “Extract Red Hat JBoss BPM Suite for Oracle WebLogic Server” => obsolete (see in my comments above)

Reviewed with BPM Suite 6.1.0 ER6

Regards,
Radek

Comment 25 Radovan Synek 2015-03-20 12:48:26 UTC
Thanks, good work. Verified with BPM Suite 6.1.0.ER6


Note You need to log in before you can comment on or make changes to this bug.