Bug 1124092 - [DOCS] BRMS Weblogic Installation & Configuration Guide
Summary: [DOCS] BRMS Weblogic Installation & Configuration Guide
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Documentation
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER3
: 6.1.0
Assignee: Dan Macpherson
QA Contact: Radovan Synek
Linda Snyder
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 00:39 UTC by Vikram Goyal
Modified: 2016-10-14 14:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-29 02:59:30 UTC
Type: Bug


Attachments (Terms of Use)
Output of BRMS exception (9.52 KB, text/plain)
2014-11-07 05:15 UTC, Dan Macpherson
no flags Details

Description Vikram Goyal 2014-07-29 00:39:40 UTC
Similar to the Websphere Installation & Configuration Guide, create a Weblogic Installation & Configuration Guide for 6.1 release based on the 6.1 PRD item: https://issues.jboss.org/browse/BPMSPL-64

Comment 3 Dan Macpherson 2014-10-29 04:06:04 UTC
I try to deploy but hit the following exception multiple times:

java.lang.RuntimeException: failed to instantiate new type: org.jboss.errai.config.rebind.EnvUtil$EnvironmentConfigCache
	at org.jboss.errai.common.rebind.CacheUtil.getCache(CacheUtil.java:46)
	at org.jboss.errai.config.rebind.EnvUtil.getEnvironmentConfig(EnvUtil.java:299)
	at org.jboss.errai.config.rebind.EnvUtil.isPortableType(EnvUtil.java:304)
	at org.jboss.errai.cdi.server.CDIExtensionPoints.processObserverMethod(CDIExtensionPoints.java:311)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
... etc ...
Caused by: java.lang.RuntimeException: could not find class defined in ErraiApp.properties for serialization: org.drools.workbench.models.guided.dtable.shared.model.DescriptionCol52
	at org.jboss.errai.config.rebind.EnvUtil.newEnvironmentConfig(EnvUtil.java:171)
	at org.jboss.errai.config.rebind.EnvUtil.access$000(EnvUtil.java:56)
	at org.jboss.errai.config.rebind.EnvUtil$EnvironmentConfigCache.clear(EnvUtil.java:66)
	at org.jboss.errai.config.rebind.EnvUtil$EnvironmentConfigCache.<init>(EnvUtil.java:61)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
... etc ...

Not sure what I can do to workaround this issue.

Just to give some testing specs:
* I'm testing it using WebLogic 12c on a local VM (using libvirt)
* Data Source is an Oracle DB running on a separate local VM (also using libvirt)
* OS for both VMs is RHEL 6.5

Any advice here would be most appreciated.

Comment 5 Vikram Goyal 2014-10-29 23:19:03 UTC
@maciej - wondering if you can help with the issues Dan has run into using the upstream documentation.

Comment 6 Maciej Swiderski 2014-10-30 10:34:36 UTC
depending on what version you use you might ran into trouble with class loaders on web logic. Latest versions should already have fix for it that ensures proper class loader is used upon deployment and start of the application. If needed (and you cannot get latest version) you can workaround it manually adding this content [1] to a file in your web logic distributions business-central.war/WEB-INF/classes/META-INF/services/javax.enterprise.inject.spi.Extension

[1] https://github.com/droolsjbpm/kie-wb-distributions/blob/master/kie-drools-wb/kie-drools-wb-distribution-wars/src/main/weblogic12/WEB-INF/classes/META-INF/services/javax.enterprise.inject.spi.Extension

Comment 7 Dan Macpherson 2014-11-07 05:15:17 UTC
Created attachment 954775 [details]
Output of BRMS exception

Okay, I fixed the class loader as per Comment #6, but now I've run into a new exception:

org.jboss.weld.exceptions.WeldException: WELD-000049 Unable to invoke [method] @PostConstruct public org.kie.workbench.drools.backend.server.AppSetup.assertPlayground() on org.kie.workbench.drools.backend.server.AppSetup@21d66aaa
    at org.jboss.weld.bean.AbstractClassBean.defaultPostConstruct(AbstractClassBean.java:405)
    at org.jboss.weld.bean.ManagedBean$ManagedBeanInjectionTarget.postConstruct(ManagedBean.java:178)
    at org.jboss.weld.bean.ManagedBean.create(ManagedBean.java:298)
    <- SNIP ->
Caused by: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    <- SNIP ->

(full log attached to this comment)


I also tried packaging and deploying the latest upstream version and I got the same exception.

Comment 8 Dan Macpherson 2014-11-07 05:17:07 UTC
Maciej, is there any advice you can give on the above?

Comment 9 Maciej Swiderski 2014-11-07 09:31:35 UTC
Dan,

check if you have file org.uberfire.java.nio.file.spi.FileSystemProvider inside business-central.war/WEB-INF/classes/META-INF/services that declares available virtual file system provides like this:
org.uberfire.java.nio.fs.jgit.JGitFileSystemProvider  # file system provider, also default (1st)
org.uberfire.java.nio.fs.file.SimpleFileSystemProvider

another note (to double check) make sure you deploy it as exploded war instead of a zipped one

Comment 10 Dan Macpherson 2014-11-07 16:09:14 UTC
Maciej,

Yep, the file's there and both lines are there (plus a commented line for eclipse provider).

Also, confirming deployment as exploded war.

Comment 12 Radovan Synek 2015-03-16 16:31:11 UTC
Dan and Vikram,

thanks for the documentation, please see my comments below:
1.1
>Red Hat JBoss BRMS for Oracle WebLogic Server is provided as a single >deployable web application archive: business-cental.war. 
There is a typo - should be "business-central". Now more serious thing - in fact, there are 2 applications - business-central.war and kie-server.war.

> Before you proceed, make sure you have root access to the server 
I don't think root access is necessary, just an access to the account WebLogic runs in should be sufficient.

2.2 - entire chapter is obsolete, as WebLogic deployable bits are now (and will be) distributed as exploded WARs

3.1
> com.sun.jersey.server.impl.cdi.lookupExtensionInBeanManager
Used only for BPM Suite, the issue this configuration solves does not happen with BRMS business central and kie-server.

> kie.services.jms.queues.response
>    JNDI name of the response queue for JMS remote API. Set to jms/KIE.RESPONSE.ALL. 

There is no need to set this property for BRMS, but there should be property kie.server.jms.queues.response specified, that does basically the same thing, but for kie-server.

3.4 ?
JMS setup is missing (required by kie-server)

Additional notes
There is a reference to Section 2.2, “Extract Red Hat JBoss BRMS for Oracle WebLogic Server” => obsolete (see in my comments above)

Reviewed with BRMS 6.1.0 ER6

Regards,
Radek

Comment 24 Radovan Synek 2015-03-19 11:07:47 UTC
Verified with BRMS-6.1.0.ER6


Note You need to log in before you can comment on or make changes to this bug.