Bug 1124101 - 'Copying' the configuration of a DHCP-configured interface to a bridge results in static addressing for the bridge
Summary: 'Copying' the configuration of a DHCP-configured interface to a bridge result...
Keywords:
Status: CLOSED DUPLICATE of bug 1122743
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 21
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 01:00 UTC by Adam Williamson
Modified: 2014-09-21 19:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-21 19:03:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1122743 None None None Never

Internal Links: 1122743

Description Adam Williamson 2014-07-29 01:00:12 UTC
I created a simple ifcfg-eth0, like so:

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

and brought it up, ensured it worked. Then I ran virt-manager, created a bridge, and told it to bridge the eth0 interface and copy the configuration to the bridge. The resulting ifcfg-br1 looks like this:

DEVICE=br1
ONBOOT=no
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.122.211
NETMASK=255.255.255.0
IPV6INIT=yes
IPV6_AUTOCONF=no
DHCPV6=no
IPV6ADDR=fe80::5054:ff:fec8:6cb5/64
STP=on
DELAY=0.0

ONBOOT=no is OK as that was an option during bridge creation, but the important thing is that it hasn't configured "BOOTPROTO=dhcp" as it should. Instead it's taken the IP addresses that were *currently* assigned to the interface via DHCP, and set up static addressing using those addresses. I'm pretty sure that's not what people would expect when 'copying' the configuration in this way.

Tested on virt-manager 1.0.1-3.fc21.1.noarch .

Comment 1 Cole Robinson 2014-09-21 19:03:15 UTC
This is the same root issue as your other bug, so duping

*** This bug has been marked as a duplicate of bug 1122743 ***


Note You need to log in before you can comment on or make changes to this bug.