Bug 1124112 - Perf: NFS random write performance dropped ~20% between .24 and .25 builds.
Summary: Perf: NFS random write performance dropped ~20% between .24 and .25 builds.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-nfs
Version: rhgs-3.0
Hardware: x86_64
OS: All
high
high
Target Milestone: ---
: ---
Assignee: Vivek Agarwal
QA Contact: Saurabh
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 02:14 UTC by Ben Turner
Modified: 2016-08-19 09:16 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-06 15:57:11 UTC


Attachments (Terms of Use)

Description Ben Turner 2014-07-29 02:14:51 UTC
Description of problem:

When running IOZone in distributed mode I am seeing an ~20% performance drop between the glusterfs-3.6.0.24-1.el6rhs.x86_64 and glusterfs-3.6.0.25-1.el6rhs.x86_64 builds.

Build                        Throughput
RHS 2.1u2                    146,064.29 KB/sec
3.6.0.24                     141,667.77 KB/sec
3.6.0.25                     111,617.25 KB/sec

Version-Release number of selected component (if applicable):

glusterfs-3.6.0.25-1.el6rhs.x86_64

How reproducible:

I have hit this every time I ran IOZone performance regression tests(5 runs in a row)

Steps to Reproduce:
1.  Setup 2x2 BAGL cluster with 4 10G clients
2.  Run IOZone:

iozone -+m /mnt/tests/rhs-tests/beaker/rhs/auto-tests/setup/rhs-setup/clients.ioz -+h gqac006.sbu.lab.eng.bos.redhat.com -C -w -c -e -i 2 -J 3 -+n -r 64k -s 2g -t 16

Actual results:

I am seeing a greater than 20% performance regression between builds .24 and .25.

Expected results:

Performance in line with earlier builds / RHS 2.1u2

Additional info:

Comment 1 Raghavendra Talur 2014-07-30 11:17:18 UTC
I am working on this. I have checked the patches that have gone into version 25,
none of them seem to have caused this.

I will run the tests on my setup once and check. Also, will check the profile data. Will update soon with findings.

Comment 7 Ben Turner 2014-10-06 15:57:11 UTC
Closing as not a bug.


Note You need to log in before you can comment on or make changes to this bug.