Bug 112415 - Installer hangs after message 'Initializing /sbin/loader'
Summary: Installer hangs after message 'Initializing /sbin/loader'
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-19 12:45 UTC by Daniel Kennedy
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 15:49:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Kennedy 2003-12-19 12:45:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When I try and boot my machine into the Fedora installer from a 
floppy disk (one from the Fedora site) it gets as far as to try and 
load /sbin/loader before hanging. It is a hard lock, and nothing 
short of pulling the battery out (yeah, I know, the manual advises 
against it) will shut it down. The last message I get from the 
console is the 'Initializing /sbin/loader' message, and then I get a 
black screen.

My hardware is:

Mitac MiNote 6020T Notebook
Pentium 3 497Mhz (Coppermine)
128Mb SDRAM
6,194 Mb Toshiba HDD (5400RPM)
ATI Mach 64-based GFX card (Actual card is an 'ATI Rage Pro 128' with 
8Mb VRAM)
Keyboard and mouse are inbuilt
TEAC 12x CDROM (internal)
Onboard sound

As a final note, I have tried the following installer options:
1. Default
2. skipddc
3. noprobe
4. text

Thanks,
Dani

Version-Release number of selected component (if applicable):
Fedora Core 1 (Stable)

How reproducible:
Always

Steps to Reproduce:
1. Load the Fedora boot floppy
2. Insert CD when prompted
3. Try whichever boot option you please
    

Actual Results:  Laptop hangs with a black screen.

Expected Results:  Installer carries on working

Additional info:

I currently have Debian 3.0r1 (stable) on the laptop (don't shoot 
me!) which uses an older version of XFree86. Fedora, on the other 
hand uses XFree86 4.3.0 I believe.

Comment 1 Jeremy Katz 2003-12-19 20:05:50 UTC
Does booting with 'linux nofb' help?

Comment 2 Daniel Kennedy 2003-12-20 15:42:02 UTC
Yes, it now boots into Anaconda without any problems! Thanks!

Comment 3 Daniel Fleseriu 2004-01-20 23:14:59 UTC
I have almost the same problem:
anaconda crashes at "running /sbin/loader"
I tried "linux nofb", results the cursor is blinking but the system 
crashes again.
everything else I  tried, system freezes and no blinking cursor. 
my system:
 -athlon xp 2200+ on msi motherboard kt4v series with via kt400 
chipset
 -512 ddram (400 samnung I gues)
 -hdd maxtor fireball3 40 gb (c:\ 10 gb system xp - uups...-; d:\ 20 
gb for everything; and 10 gb for Fedora red hat); please don't let me 
down cause I use winxp for some reason...
  -asus cdrom 50x
  -logitech cordless mouse & keyboard
  -modem internal intel 5628
  -network on board via rhine II fast ethernet
  -display sony multiscan 20 se
  -sound sb live!
  -tv tunner pinnacle pro
thank you

Comment 4 Jay Douglass 2004-02-14 04:24:02 UTC
I've got this problem too.

I'm attempting to install Fedora Core 1 from a cdrom.  Nofb, noprobe, text, and several other boot options I thought could help me didn't work.  Same result everytime: hard hang at /sbin/loader.

I've yet to try other media sources for installation.

I installed RH 8 earlier with no installation problems.  The only difference between my system at the time I installed RH 8 and my system now is a new motherboard, an Abit KV7.  The mobo at the time of the RH 8 installation was a leaky Gigabyte 7VRXP.  No change in peripherals.  

I read that some USB controllers might be causing problems at /sbin/loader.  The KV7 uses a standard VIA USB 2.0 controller.

No exotic hardware except possibly an onboard SATA RAID controller which is not in use and is disabled in BIOS.

I confirmed the md5s on the isos I used.  'linux mediacheck' didn't work because it crashed at /sbin/loader too.

system:
Athlon XP 2000+ 
Abit KV7 mobo with via KT600 chipset
Pioneer DVD-ROM 106
Nvidia GeForce Ti 4600
Via onboard ethernet
Please ask if any more information would be useful.


Comment 5 Jay Douglass 2004-02-14 05:24:50 UTC
nousb got me past the /sbin/loader hang, but now it is hanging in 
kudzu (I believe) after trying to detect the monitor.



Comment 6 Mike Insch 2004-04-06 16:03:28 UTC
I had exactly the same problem with a new Athlon XP 2600+, 1GB RAM on
an MSI KT6V-LSR motherboard.  The critical factor turned out to be
"USB Legacy Support" being enabled in the BIOS (I use a USB mouse, so
had it enabled because I had needed it before).

With this setting enabled, the boot would reach /sbin/loader, the
cursor would flash exactly three times, then stop - the system would
freeze.  Similar effect with "linux nofb", though "linux nousb
nopcmcia nofirewire nofb" did get all the way to the text mode
installer OK.

I disabled USB Legacy Support in the BIOS (it's under "Integrated
Peripherals"), and the installer starts just fine.


Comment 7 marco palloni 2004-05-02 20:11:50 UTC
I have a similar problem with core2 test3 , when I start to install 
system hung and no more run.

I have a P4-2400 with ASUS P4P800 and 5 IDE unit (2 PATA+CD+DVD+1 
SATA).
- ATI 9500 Pro + Syncmaster 171 (LCD).
- On board 3COM 2000 NIC.

With old release (test 2) system start and hang during partitioning.

With test 3 system non start initially.

Thanks for your help.

Comment 8 Jeremy Katz 2004-10-05 15:49:32 UTC
This should be happier with current releases.

Comment 9 Conai Vance 2006-01-06 09:11:31 UTC
I have the same problem installing FC4 on my laptop. It freezes after it
displays the /sbin/loader... I have tried linux nofb but still it doesn't work.
Help needed please...

--
Asus A6B00R Laptop
Intel Celeron M Processor 370
ATI Radeon Express 200M
15.4 WXGA TFT LCD


Note You need to log in before you can comment on or make changes to this bug.