Bug 112424 - When using samba with XP pro, large number of errors in /var/log/messages appear.
When using samba with XP pro, large number of errors in /var/log/messages app...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
athlon Linux
high Severity high
: ---
: ---
Assigned To: Jay Fenlason
:
: 112431 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-19 10:45 EST by Kimo Bonnelycke
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-22 10:07:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kimo Bonnelycke 2003-12-19 10:45:26 EST
Version of samba  3.0.0-14.3E

When using samba share on windows machine, transfer speeds start fast,
and then performance drops dramatically.  I checked /var/log/messages,
and I am recieveing the following message:

Dec 18 15:47:10 fileserver samba(pam_unix)[20621]: session opened for
user Administrator by (uid=0)
Dec 18 15:47:10 fileserver smbd[20621]: [2003/12/18 15:47:10, 0]
lib/fault.c:fault_report(36) 
Dec 18 15:47:10 fileserver smbd[20621]:  
=============================================================== 
Dec 18 15:47:10 fileserver smbd[20621]: [2003/12/18 15:47:10, 0]
lib/fault.c:fault_report(37) 
Dec 18 15:47:10 fileserver smbd[20621]:   INTERNAL ERROR: Signal 11 in
pid 20621 (3.0.0-14.3E) 
Dec 18 15:47:10 fileserver smbd[20621]:   Please read the appendix
Bugs of the Samba HOWTO collection 
Dec 18 15:47:10 fileserver smbd[20621]: [2003/12/18 15:47:10, 0]
lib/fault.c:fault_report(39) 
Dec 18 15:47:10 fileserver smbd[20621]:  
=============================================================== 
Dec 18 15:47:10 fileserver smbd[20621]: [2003/12/18 15:47:10, 0]
lib/util.c:smb_panic(1422) 
Dec 18 15:47:10 fileserver smbd[20621]:   PANIC: internal error 
Dec 18 15:47:10 fileserver smbd[20621]: [2003/12/18 15:47:10, 0]
lib/util.c:smb_panic(1429) 
Dec 18 15:47:10 fileserver smbd[20621]:   BACKTRACE: 18 stack frames: 
Dec 18 15:47:10 fileserver smbd[20621]:    #0 smbd(smb_panic+0x11c)
[0x81bbedc] 
Dec 18 15:47:10 fileserver smbd[20621]:    #1 smbd [0x81aa652] 
Dec 18 15:47:10 fileserver smbd[20621]:    #2 /lib/tls/libc.so.6
[0xb7266c08] 
Dec 18 15:47:10 fileserver smbd[20621]:    #3 smbd(unix_strupper+0x36)
[0x81a85d6] 
Dec 18 15:47:10 fileserver smbd[20621]:    #4 smbd(strupper_m+0x42)
[0x81b5002] 
Dec 18 15:47:10 fileserver smbd[20621]:    #5 smbd [0x80d056a] 
Dec 18 15:47:10 fileserver smbd[20621]:    #6 smbd [0x80d0fe2] 
Dec 18 15:47:10 fileserver smbd[20621]:    #7 smbd(mangle_map+0x82)
[0x80cef02] 
Dec 18 15:47:10 fileserver smbd[20621]:    #8 smbd [0x80ab80a] 
Dec 18 15:47:11 fileserver smbd[20621]:    #9 smbd [0x80ac07c] 
Dec 18 15:47:11 fileserver smbd[20621]:    #10
smbd(reply_trans2+0x69c) [0x80b3e4c] 
Dec 18 15:47:11 fileserver smbd[20621]:    #11 smbd [0x80c7286] 
Dec 18 15:47:11 fileserver smbd[20621]:    #12 smbd [0x80c7459] 
Dec 18 15:47:11 fileserver smbd[20621]:    #13 smbd(process_smb+0x8f)
[0x80c766f] 
Dec 18 15:47:11 fileserver smbd[20621]:    #14
smbd(smbd_process+0x167) [0x80c82a7] 
Dec 18 15:47:11 fileserver smbd[20621]:    #15 smbd(main+0x4bf)
[0x822407f] 
Dec 18 15:47:11 fileserver smbd[20621]:    #16
/lib/tls/libc.so.6(__libc_start_main+0xf8) [0xb7254748] 
Dec 18 15:47:11 fileserver smbd[20621]:    #17 smbd(ldap_msgfree+0x69)
[0x8076ba1] 
Dec 18 15:47:11 fileserver smbd[20621]: 
Dec 18 15:47:11 fileserver samba(pam_unix)[20622]: session opened for
user Administrator by (uid=0)
Dec 18 15:47:11 fileserver smbd[20622]: [2003/12/18 15:47:11, 0]
lib/fault.c:fault_report(36) 
Dec 18 15:47:11 fileserver smbd[20622]:  
=============================================================== 
Dec 18 15:47:11 fileserver smbd[20622]: [2003/12/18 15:47:11, 0]
lib/fault.c:fault_report(37) 
Dec 18 15:47:11 fileserver smbd[20622]:   INTERNAL ERROR: Signal 11 in
pid 20622 (3.0.0-14.3E) 
Dec 18 15:47:11 fileserver smbd[20622]:   Please read the appendix
Bugs of the Samba HOWTO collection 
Dec 18 15:47:11 fileserver smbd[20622]: [2003/12/18 15:47:11, 0]
lib/fault.c:fault_report(39) 
Dec 18 15:47:11 fileserver smbd[20622]:  
=============================================================== 
Dec 18 15:47:11 fileserver smbd[20622]: [2003/12/18 15:47:11, 0]
lib/util.c:smb_panic(1422) 
Dec 18 15:47:11 fileserver smbd[20622]:   PANIC: internal error 
Dec 18 15:47:11 fileserver smbd[20622]: [2003/12/18 15:47:11, 0]
lib/util.c:smb_panic(1429) 
Dec 18 15:47:11 fileserver smbd[20622]:   BACKTRACE: 18 stack frames: 
Dec 18 15:47:11 fileserver smbd[20622]:    #0 smbd(smb_panic+0x11c)
[0x81bbedc] 
Dec 18 15:47:11 fileserver smbd[20622]:    #1 smbd [0x81aa652] 
Dec 18 15:47:11 fileserver smbd[20622]:    #2 /lib/tls/libc.so.6
[0xb7266c08] 
Dec 18 15:47:11 fileserver smbd[20622]:    #3 smbd(unix_strupper+0x36)
[0x81a85d6] 
Dec 18 15:47:11 fileserver smbd[20622]:    #4 smbd(strupper_m+0x42)
[0x81b5002] 
Dec 18 15:47:11 fileserver smbd[20622]:    #5 smbd [0x80d056a] 
Dec 18 15:47:11 fileserver smbd[20622]:    #6 smbd [0x80d0fe2] 
Dec 18 15:47:11 fileserver smbd[20622]:    #7 smbd(mangle_map+0x82)
[0x80cef02] 
Dec 18 15:47:11 fileserver smbd[20622]:    #8 smbd [0x80ab80a] 
Dec 18 15:47:11 fileserver smbd[20622]:    #9 smbd [0x80ac07c] 
Dec 18 15:47:11 fileserver smbd[20622]:    #10
smbd(reply_trans2+0x69c) [0x80b3e4c] 
Dec 18 15:47:11 fileserver smbd[20622]:    #11 smbd [0x80c7286] 
Dec 18 15:47:11 fileserver smbd[20622]:    #12 smbd [0x80c7459] 
Dec 18 15:47:11 fileserver smbd[20622]:    #13 smbd(process_smb+0x8f)
[0x80c766f] 
Dec 18 15:47:11 fileserver smbd[20622]:    #14
smbd(smbd_process+0x167) [0x80c82a7] 
Dec 18 15:47:11 fileserver smbd[20622]:    #15 smbd(main+0x4bf)
[0x822407f] 
Dec 18 15:47:11 fileserver smbd[20622]:    #16
/lib/tls/libc.so.6(__libc_start_main+0xf8) [0xb7254748] 
Dec 18 15:47:11 fileserver smbd[20622]:    #17 smbd(ldap_msgfree+0x69)
[0x8076ba1] 
Dec 18 15:47:11 fileserver smbd[20622]: 
Dec 18 15:47:11 fileserver samba(pam_unix)[20623]: session opened for
user Administrator by (uid=0)
Dec 18 15:47:11 fileserver smbd[20623]: [2003/12/18 15:47:11, 0]
lib/fault.c:fault_report(36) 
Dec 18 15:47:11 fileserver smbd[20623]:  
=============================================================== 
Dec 18 15:47:11 fileserver smbd[20623]: [2003/12/18 15:47:11, 0]
lib/fault.c:fault_report(37) 
Dec 18 15:47:12 fileserver smbd[20623]:   INTERNAL ERROR: Signal 11 in
pid 20623 (3.0.0-14.3E) 
Dec 18 15:47:12 fileserver smbd[20623]:   Please read the appendix
Bugs of the Samba HOWTO collection 
Dec 18 15:47:12 fileserver smbd[20623]: [2003/12/18 15:47:12, 0]
lib/fault.c:fault_report(39) 
Dec 18 15:47:12 fileserver smbd[20623]:  
=============================================================== 
Dec 18 15:47:12 fileserver smbd[20623]: [2003/12/18 15:47:12, 0]
lib/util.c:smb_panic(1422) 
Dec 18 15:47:12 fileserver smbd[20623]:   PANIC: internal error 
Dec 18 15:47:12 fileserver smbd[20623]: [2003/12/18 15:47:12, 0]
lib/util.c:smb_panic(1429) 
Dec 18 15:47:12 fileserver smbd[20623]:   BACKTRACE: 18 stack frames: 
Dec 18 15:47:12 fileserver smbd[20623]:    #0 smbd(smb_panic+0x11c)
[0x81bbedc] 
Dec 18 15:47:12 fileserver smbd[20623]:    #1 smbd [0x81aa652] 
Dec 18 15:47:12 fileserver smbd[20623]:    #2 /lib/tls/libc.so.6
[0xb7266c08] 
Dec 18 15:47:12 fileserver smbd[20623]:    #3 smbd(unix_strupper+0x36)
[0x81a85d6] 
Dec 18 15:47:12 fileserver smbd[20623]:    #4 smbd(strupper_m+0x42)
[0x81b5002] 
Dec 18 15:47:12 fileserver smbd[20623]:    #5 smbd [0x80d056a] 
Dec 18 15:47:12 fileserver smbd[20623]:    #6 smbd [0x80d0fe2] 
Dec 18 15:47:12 fileserver smbd[20623]:    #7 smbd(mangle_map+0x82)
[0x80cef02] 
Dec 18 15:47:12 fileserver smbd[20623]:    #8 smbd [0x80ab80a] 
Dec 18 15:47:12 fileserver smbd[20623]:    #9 smbd [0x80ac07c] 
Dec 18 15:47:12 fileserver smbd[20623]:    #10
smbd(reply_trans2+0x69c) [0x80b3e4c] 
Dec 18 15:47:12 fileserver smbd[20623]:    #11 smbd [0x80c7286] 
Dec 18 15:47:12 fileserver smbd[20623]:    #12 smbd [0x80c7459] 
Dec 18 15:47:12 fileserver smbd[20623]:    #13 smbd(process_smb+0x8f)
[0x80c766f] 
Dec 18 15:47:12 fileserver smbd[20623]:    #14
smbd(smbd_process+0x167) [0x80c82a7] 
Dec 18 15:47:12 fileserver smbd[20623]:    #15 smbd(main+0x4bf)
[0x822407f] 
Dec 18 15:47:12 fileserver smbd[20623]:    #16
/lib/tls/libc.so.6(__libc_start_main+0xf8) [0xb7254748] 
Dec 18 15:47:12 fileserver smbd[20623]:    #17 smbd(ldap_msgfree+0x69)
[0x8076ba1] 
Dec 18 15:47:12 fileserver smbd[20623]: 


The above messages seem to be never ending, and has made my messages
file over 17megs in size.  If I stop the windows share function, the
errors stop.  I have restarted samba, but the problem still happens.  

FYI, I was using MusicMatch to view a large samba share of MP3's.

Kimo
Comment 1 Kimo Bonnelycke 2003-12-29 22:38:43 EST
*** Bug 112431 has been marked as a duplicate of this bug. ***
Comment 2 Kimo Bonnelycke 2003-12-29 22:45:29 EST
Any update to this issue?  I am including my smb.conf file..

I tried setting some charsets, but that did not resolve the issue.

Kimo

# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options (perhaps too
# many!) most of which are not shown in this example
#
# Any line which starts with a ; (semi-colon) or a # (hash)
# is a comment and is ignored. In this example we will use a #
# for commentry and a ; for parts of the config file that you
# may wish to enable
#
# NOTE: Whenever you modify this file you should run the command
"testparm"
# to check that you have not made any basic syntactic errors.
#
#======================= Global Settings
=====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
    workgroup = MYNET

# server string is the equivalent of the NT Description field
    server string = Samba Server

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
    hosts allow = 10.0.0.3 10.0.0.4 10.0.0.100

# if you want to automatically load your printer list rather
# than setting them up individually then you'll need this
    printcap name = /etc/printcap
    load printers = no

# It should not be necessary to spell out the print system type unless
# yours is non-standard. Currently supported print systems include:
# bsd, sysv, plp, lprng, aix, hpux, qnx
    printing = lprng

# Uncomment this if you want a guest account, you must add this to
/etc/passwd
# otherwise the user "nobody" is used
;  guest account = pcguest

# this tells Samba to use a separate log file for each machine
# that connects
    log file = /var/log/samba/%m.log

# Put a capping on the size of the log files (in Kb).
    max log size = 0

# Security mode. Most people will want user level security. See
# security_level.txt for details.
    security = user
#	security = SHARE

# Use password server option only with security = server
# The argument list may include:
#   password server = My_PDC_Name [My_BDC_Name] [My_Next_BDC_Name]
# or to auto-locate the domain controller/s
#   password server = *
;   password server = <NT-Server-Name>

# Password Level allows matching of _n_ characters of the password for
# all combinations of upper and lower case.
;  password level = 8
;  username level = 8

# You may wish to use password encryption. Please read
# ENCRYPTION.txt, Win95.txt and WinNT.txt in the Samba documentation.
# Do not enable this option unless you have read those documents
    encrypt passwords = yes
    smb passwd file = /etc/samba/smbpasswd

# The following is needed to keep smbclient from spouting spurious errors
# when Samba is built with support for SSL.
;   ssl CA certFile = /usr/share/ssl/certs/ca-bundle.crt

# The following are needed to allow password changing from Windows to
# update the Linux sytsem password also.
# NOTE: Use these with 'encrypt passwords' and 'smb passwd file' above.
# NOTE2: You do NOT need these to allow workstations to change only
#        the encrypted SMB passwords. They allow the Unix password
#        to be kept in sync with the SMB password.
    unix password sync = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n
*passwd:*all*authentication*tokens*updated*successfully*

# You can use PAM's password change control flag for Samba. If
# enabled, then PAM will be used for password changes when requested
# by an SMB client instead of the program listed in passwd program.
# It should be possible to enable this without changing your passwd
# chat parameter for most setups.

    pam password change = yes

# Unix users can map to different SMB User names
;  username map = /etc/samba/smbusers

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /etc/samba/smb.conf.%m

# This parameter will control whether or not Samba should obey PAM's
# account and session management directives. The default behavior is
# to use PAM for clear text authentication only and to ignore any
# account or session management. Note that Samba always ignores PAM
# for authentication in the case of encrypt passwords = yes

    obey pam restrictions = yes

# Most people will find that this option gives better performance.
# See speed.txt and the manual pages for details
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

# Configure Samba to use multiple interfaces
# If you have multiple network interfaces then you must list them
# here. See the man page for details.
;   interfaces = 192.168.12.2/24 192.168.13.2/24

# Configure remote browse list synchronisation here
#  request announcement to, or browse list sync from:
#	a specific host or from / to a whole subnet (see below)
;   remote browse sync = 192.168.3.25 192.168.5.255
# Cause this host to announce itself to local subnets here
;   remote announce = 192.168.1.255 192.168.2.44

# Browser Control Options:
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
;   local master = no

# OS Level determines the precedence of this server in master browser
# elections. The default value should be reasonable
;   os level = 33

# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
;   domain master = yes

# Preferred Master causes Samba to force a local browser election on
startup
# and gives it a slightly higher chance of winning the election
;   preferred master = yes

# Enable this if you want Samba to be a domain logon server for
# Windows95 workstations.
;   domain logons = yes

# if you enable domain logons then you may want a per-machine or
# per user logon script
# run a specific logon batch file per workstation (machine)
;   logon script = %m.bat
# run a specific logon batch file per username
;   logon script = %U.bat

# Where to store roving profiles (only for Win95 and WinNT)
#        %L substitutes for this servers netbios name, %U is username
#        You must uncomment the [Profiles] share below
;   logon path = \\%L\Profiles\%U

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable it's WINS
Server
;   wins support = yes

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
#	Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# WINS Proxy - Tells Samba to answer name resolution queries on
# behalf of a non WINS capable client, for this to work there must be
# at least one	WINS Server on the network. The default is NO.
;   wins proxy = yes

# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
# via DNS nslookups. The built-in default for versions 1.9.17 is yes,
# this has been changed in version 1.9.18 to no.
    dns proxy = no

# Case Preservation can be handy - system default is _no_
# NOTE: These can be set on a per share basis
;  preserve case = no
;  short preserve case = no
# Default case is normally upper case for all DOS files
;  default case = lower
# Be very careful with case sensitivity - it can break things!
;  case sensitive = no

#unix charset = ISO8859-1
#dos charset = CP850


#============================ Share Definitions
==============================
[homes]
    comment = Home Directories
    browseable = no
    writable = yes
    valid users = %S
    create mode = 0664
    directory mode = 0775
# If you want users samba doesn't recognize to be mapped to a guest user
; map to guest = bad user


# Un-comment the following and create the netlogon directory for
Domain Logons
; [netlogon]
;   comment = Network Logon Service
;   path = /usr/local/samba/lib/netlogon
;   guest ok = yes
;   writable = no
;   share modes = no


# Un-comment the following to provide a specific roving profile share
# the default is to use the user's home directory
;[Profiles]
;    path = /usr/local/samba/profiles
;    browseable = no
;    guest ok = yes


# NOTE: If you have a BSD-style print system there is no need to
# specifically define each individual printer
[printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = yes
# Set public = yes to allow user 'guest account' to print
    public = yes
    writable = no
    printable = yes
    available = yes

# This one is useful for people to share files
;[tmp]
;   comment = Temporary file space
;   path = /tmp
;   read only = no
;   public = yes

# A publicly accessible directory, but read only, except for people in
# the "staff" group
;[public]
;   comment = Public Stuff
;   path = /home/samba
;   public = yes
;   writable = yes
;   printable = no
;   write list = @staff

# Other examples.
#
# A private printer, usable only by fred. Spool data will be placed in
fred's
# home directory. Note that fred must have write access to the spool
directory,
# wherever it is.
;[fredsprn]
;   comment = Fred's Printer
;   valid users = fred
;   path = /home/fred
;   printer = freds_printer
;   public = no
;   writable = no
;   printable = yes

# A private directory, usable only by fred. Note that fred requires write
# access to the directory.
;[fredsdir]
;   comment = Fred's Service
;   path = /usr/somewhere/private
;   valid users = fred
;   public = no
;   writable = yes
;   printable = no

# a service which has a different directory for each machine that connects
# this allows you to tailor configurations to incoming machines. You could
# also use the %U option to tailor it by user name.
# The %m gets replaced with the machine name that is connecting.
;[pchome]
;  comment = PC Directories
;  path = /usr/local/pc/%m
;  public = no
;  writable = yes

# A publicly accessible directory, read/write to all users. Note that
all files
# created in the directory by users will be owned by the default user, so
# any user with access can delete any other user's files. Obviously this
# directory must be writable by the default user. Another user could
of course
# be specified, in which case all files would be owned by that user
instead.
;[public]
;   path = /usr/somewhere/else/public
;   public = yes
;   only guest = yes
;   writable = yes
;   printable = no

# The following two entries demonstrate how to share a directory so
that two
# users can place files there that will be owned by the specific
users. In this
# setup, the directory should be writable by both users and should
have the
# sticky bit set on it to prevent abuse. Obviously this could be
extended to
# as many users as required.
[data]
    path = /data
    public = no
    writable = yes
    printable = no
    valid users = Administrator
[mp3]
    path = /mp3
    public = no
    writable = yes
    printable = no
    valid users = Administrator
[http]
    path = /data/http
    public = no
    writable = yes
    printable = no
    valid users = Administrator
[downloads]
    path = /data/downloads
    public = no
    writable = yes
    printable = no
    valid users = Administrator
Comment 3 Jay Fenlason 2004-01-16 23:58:05 EST
I've put RPMs of samba-3.0.2rc1 on 
http://people.redhat.com/fenlason/.samba .  Can you try them and see if 
they resolve your problem.  Note that these are un-qa'd packages of a 
release that is not intended for production use.  If they solve your 
problem, I will attempt to get samba-3.0.2 included in the next quarterly 
update of Red Hat Enterprise Linux 3. 
Comment 4 Kimo Bonnelycke 2004-01-19 10:22:04 EST
I have downloaded, and installed the requested samba files.  I am
currently testing them out, and will supply the results later today
(01/19/04)

Thx

Kimo B.
Comment 5 Kimo Bonnelycke 2004-01-19 12:45:44 EST
Jay,

I have done some testing of the above code.  So far there does not
appear to be any issues.  I have done multiple 1 gig transfers (both
ways, at the same time, with other access requests going on) and
everything seems great.  

Thx for the rpms...

Kimo B.
Comment 6 Jay Fenlason 2004-02-04 16:29:12 EST
I've built new rpms from samba-3.0.2rc2, if you want to try them out.
They're in the http://people.redhat.com/fenlason/.samba/ directory.
When 3.0.2 final is released, I'll try to get it included in the next
quarterly update.
Comment 7 Kimo Bonnelycke 2004-02-04 16:36:02 EST
I have downloaded them, and will give them a shot.

Kimo B.
Comment 8 Jay Fenlason 2004-10-21 15:07:05 EDT
Are you still seeing this problem with current RPMs?  If current rpms work I'm 
going to close this. 
Comment 9 Kimo Bonnelycke 2004-10-22 04:22:19 EDT
Ohh, sorry.  Everything is working great.  (the RPMS you provided 
solved the issue, and all updates rpms seemed to keep the problem 
fixed).

Cheers.

Kimo B.

Note You need to log in before you can comment on or make changes to this bug.