Bug 112429 - find-debuginfo.sh fails to strip readonly object files, all perl modules
Summary: find-debuginfo.sh fails to strip readonly object files, all perl modules
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-19 16:29 UTC by Ross M.
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-28 15:33:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
possible fix (520 bytes, patch)
2003-12-19 16:34 UTC, Ross M.
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:098 normal SHIPPED_LIVE Updated rpm package fixes several bugs 2004-05-12 04:00:00 UTC

Description Ross M. 2003-12-19 16:29:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
perl rpms install their lib data read-only. when the find-debuginfo.sh
script runs it tries to strip the files but can't leaving huge rpms in
many cases because of the debugging synbols. (found while developing
perl-Glib/perl-Gtk2, http://gtk2-perl.sourceforge.net/) the script's
call to eu-string prints an error message near the end of the build
process saying as much.



Version-Release number of selected component (if applicable):
rpm-build-4.2.1-0.30

How reproducible:
Always

Steps to Reproduce:
1. building most any perl rpm seems to show this problem, perl-Glib.


Additional info:

/usr/share/man/man3/Glib::ParamSpec.3pm.gzX' = X ']'
+ /usr/lib/rpm/find-debuginfo.sh /home/rmcfarla/rpms/BUILD/Glib-1.030
extracting debug info from
/var/tmp/perl-Glib-1.030-1-root/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi/auto/Glib/Glib.so
eu-strip: while opening
"/var/tmp/perl-Glib-1.030-1-root/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi/auto/Glib/Glib.so":
Permission denied
408 blocks
+ /usr/lib/rpm/redhat/brp-compress

Comment 1 Ross M. 2003-12-19 16:34:23 UTC
Created attachment 96637 [details]
possible fix

patch that fixes the problem by temporarily u+w and then u-w, only if
non-writeable.

Comment 2 Jeff Johnson 2003-12-28 15:33:34 UTC
Added in CVS, should be in rpm-4.2.2-0.8 and later.

Comment 3 John Flanagan 2004-05-12 04:27:23 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-098.html


Comment 4 Kenneth Porter 2004-06-28 23:57:20 UTC
brp-strip suffers from the same issue in rpm-4.3.1-0.3 issued with
Fedora Core 2. Found while building spamassassin-3.0-pre1, which uses
ExtUtils::Install to install ELF binary spamc mode 555:

http://bugzilla.spamassassin.org/show_bug.cgi?id=3535


Note You need to log in before you can comment on or make changes to this bug.