Bug 1124317 - guest will paused after do snapshot-revert to a external snapshot
Summary: guest will paused after do snapshot-revert to a external snapshot
Keywords:
Status: CLOSED DUPLICATE of bug 1124854
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Krempa
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 08:34 UTC by Luyao Huang
Modified: 2014-08-08 13:19 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 13:19:34 UTC


Attachments (Terms of Use)

Description Luyao Huang 2014-07-29 08:34:48 UTC
Description of problem:
guest will paused after do snapshot-revert to a external snapshot and guest's xml have multifunction='on' usb controller.

Version-Release number of selected component (if applicable):
libvirt-0.10.2-41.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.431.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.# virsh dumpxml test6
.....
 <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2' cache='none'/>
      <source file='/var/lib/libvirt/images/test6.img'/>
      <target dev='hda' bus='ide'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    </disk>
....
<controller type='usb' index='0' model='ich9-ehci1'>
      <alias name='usb0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x7'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <alias name='usb0'/>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0' multifunction='on'/>
    </controller>
....
2.# virsh snapshot-create-as test6 s8 --memspec file=/tmp/s8.mem --diskspec hda,file=/tmp/s8.img --live
Domain snapshot s8 created

 


3.# virsh dumpxml test6

 <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2' cache='none'/>
      <source file='/tmp/s8.img'/>
      <target dev='hda' bus='ide'/>
      <alias name='ide0-0-0'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    </disk>

4.# virsh list --all
 Id    Name                           State
----------------------------------------------------
 39    test6                          running



5.# virsh snapshot-revert test6 s8
error: Requested operation is not valid: the snapshot 's8' does not exist, and was not loaded

6.# virsh list --all
 Id    Name                           State
----------------------------------------------------
 39    test6                          paused





Actual results:
guest status have been changed to paused after snapshot-revert

Expected results:
guest still running and error report should be:
error: unsupported configuration: revert to external disk snapshot not supported yet

Additional info:
Shanzhi Yu:
"
 <controller type='usb' index='0' model='ich9-ehci1'>
      <alias name='usb0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x7'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <alias name='usb0'/>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0' multifunction='on'/>
    </controller>
"
since this is the point to reproduce this bug.

Comment 2 Jiri Denemark 2014-08-08 13:19:34 UTC

*** This bug has been marked as a duplicate of bug 1124854 ***


Note You need to log in before you can comment on or make changes to this bug.