Bug 1124321
| Summary: | NPE when live migrating a disk - using REST and SDK APIs. | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [Retired] oVirt | Reporter: | Raz Tamir <ratamir> | ||||
| Component: | ovirt-engine-core | Assignee: | Vered Volansky <vered> | ||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Raz Tamir <ratamir> | ||||
| Severity: | high | Docs Contact: | |||||
| Priority: | unspecified | ||||||
| Version: | 3.5 | CC: | amureini, bugs, ecohen, gklein, iheim, rbalakri, vered, yeylon | ||||
| Target Milestone: | --- | Keywords: | AutomationBlocker | ||||
| Target Release: | 3.5.0 | ||||||
| Hardware: | Unspecified | ||||||
| OS: | Unspecified | ||||||
| Whiteboard: | storage | ||||||
| Fixed In Version: | ovirt-3.5.0_rc1.1 | Doc Type: | Bug Fix | ||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2014-10-17 12:32:13 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | Storage | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Bug Depends On: | |||||||
| Bug Blocks: | 1103499 | ||||||
| Attachments: |
|
||||||
|
Description
Raz Tamir
2014-07-29 08:48:56 UTC
According to the logs [1], the canDo failed on 'StorageDomainValidator -> hasSpaceForNewDisks' validation. @Vered - can you please check that? [1] 2014-07-29 11:12:00,529 ERROR [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (ajp--127.0.0.1-8702-11) [3808ff98] Error during CanDoActionFailure.: java.lang.NullPointerException at org.ovirt.engine.core.bll.validator.StorageDomainValidator.hasSpaceForNewDisks(StorageDomainValidator.java:112) [bll.jar:] at org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand.validateSourceDomainsSpaceRequirements(LiveMigrateVmDisksCommand.java:445) [bll.jar:] Yes, next on my list. The cause for this is that the source storage domain id passed as parameter is empty GUID, instead of actual source domain. This is also the case for cold move and copy, which should be handled in this bug and verified. Update: The NPE occurs every time performing LSM, even when source and destination domains are not the same (In reply to ratamir from comment #4) > Update: The NPE occurs every time performing LSM, even when source and > destination domains are not the same That's not surprising, the patch should solve all issues, waiting for review. Please make sure to verify according to comment #3 as well when the time comes, thanks. Verified on - ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch oVirt 3.5 has been released and should include the fix for this issue. |