Bug 1124321 - NPE when live migrating a disk - using REST and SDK APIs.
Summary: NPE when live migrating a disk - using REST and SDK APIs.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Vered Volansky
QA Contact: Raz Tamir
URL:
Whiteboard: storage
Depends On:
Blocks: 1103499
TreeView+ depends on / blocked
 
Reported: 2014-07-29 08:48 UTC by Raz Tamir
Modified: 2016-02-10 16:52 UTC (History)
8 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:32:13 UTC
oVirt Team: Storage


Attachments (Terms of Use)
engine log (470.61 KB, text/plain)
2014-07-29 08:48 UTC, Raz Tamir
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30975 master MERGED restapi: Fix NPE when live migrating a disk Never
oVirt gerrit 31339 ovirt-engine-3.5 MERGED restapi: Fix NPE when live migrating a disk Never

Description Raz Tamir 2014-07-29 08:48:56 UTC
Created attachment 922069 [details]
engine log

Description of problem:
Tried to reproduce this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1103499.

The result is NPE:
2014-07-29 11:12:00,529 ERROR [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (ajp--127.0.0.1-8702-11) [3808ff98] Error during CanDoActionFailure.: java.lang.NullPointerException

** engine log attached


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Daniel Erez 2014-07-29 12:35:05 UTC
According to the logs [1], the canDo failed on 'StorageDomainValidator -> hasSpaceForNewDisks' validation.

@Vered - can you please check that?

[1]
2014-07-29 11:12:00,529 ERROR [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (ajp--127.0.0.1-8702-11) [3808ff98] Error during CanDoActionFailure.: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.validator.StorageDomainValidator.hasSpaceForNewDisks(StorageDomainValidator.java:112) [bll.jar:]
	at org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand.validateSourceDomainsSpaceRequirements(LiveMigrateVmDisksCommand.java:445) [bll.jar:]

Comment 2 Vered Volansky 2014-07-31 07:47:52 UTC
Yes, next on my list.

Comment 3 Vered Volansky 2014-08-03 18:46:35 UTC
The cause for this is that the source storage domain id passed as parameter is empty GUID, instead of actual source domain. This is also the case for cold move and copy, which should be handled in this bug and verified.

Comment 4 Raz Tamir 2014-08-11 06:59:12 UTC
Update: The NPE occurs every time performing LSM, even when source and destination domains are not the same

Comment 5 Vered Volansky 2014-08-11 08:41:37 UTC
(In reply to ratamir from comment #4)
> Update: The NPE occurs every time performing LSM, even when source and
> destination domains are not the same

That's not surprising, the patch should solve all issues, waiting for review. Please make sure to verify according to comment #3 as well when the time comes, thanks.

Comment 6 Raz Tamir 2014-08-24 14:21:08 UTC
Verified on - ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch

Comment 7 Sandro Bonazzola 2014-10-17 12:32:13 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.