Bug 1124327 - katello-installer --help displays currently configured settings as 'default'
Summary: katello-installer --help displays currently configured settings as 'default'
Keywords:
Status: CLOSED DUPLICATE of bug 1402061
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 09:06 UTC by Rich Jerrido
Modified: 2017-01-06 09:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-06 09:39:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 15903 None None None 2016-07-29 14:25:09 UTC

Description Rich Jerrido 2014-07-29 09:06:48 UTC
Description of problem:

When running `katello-installer --help` after installing or changing settings, katello-installer displays the currently configured values as 'default'. The effect of this is that the end-user will see differing values as 'default' depending on how their Satellite installation is configured.  This behavior has the potential of confusing the end-user. 


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install Satellite with default configuration (e.g. run katello-installer with no additional options)
2. Note the configuration of a feature (e.g. katello-installer --help | grep tftp) shows:
    --capsule-tftp                Use TFTP (default: false)

3. Enable the TFTP proxy (katello-installer --capsule-tftp)
4. Note the configuration of a feature (e.g. katello-installer --help | grep tftp) shows:
    --capsule-tftp                Use TFTP (default: true)

Expected results:

Currently, the meaning of 'default' as expressed means 'default values for all future invocations of katello-installer'. However, the user expects default to mean "values 'as shipped from the factory'". 

It would make sense to change 'default' to reflect 'current' as well as documenting the 'factory shipped defaults' (either in katello-installer --help or elsewhere) such as (as an example):

    --capsule-tftp                Use TFTP (current: true | default: false)

Comment 1 RHEL Product and Program Management 2014-07-29 09:13:55 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Stephen Benjamin 2016-07-29 14:25:07 UTC
Created redmine issue http://projects.theforeman.org/issues/15903 from this bug

Comment 5 Bryan Kearney 2016-12-02 17:04:37 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/15903 has been resolved.

Comment 7 Marek Hulan 2017-01-06 09:39:09 UTC
I think this is a duplicate of BZ 1402061 so I'm closing it. I see that this one has been opened earlier but the second has more information about the upstream fix. Please reopen if I misunderstood.

*** This bug has been marked as a duplicate of bug 1402061 ***


Note You need to log in before you can comment on or make changes to this bug.