Bug 112435 - New working LG LST-D400 wireless modem for kudzu
New working LG LST-D400 wireless modem for kudzu
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-19 12:38 EST by Avi Alkalay
Modified: 2014-03-16 22:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 14:25:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Avi Alkalay 2003-12-19 12:38:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
The LG LST-D400 modem is working perfectly on my FC1, but Kudzu didn't configured it corretly.

Solution bellow...


Version-Release number of selected component (if applicable):
kudzu-1.1.36-1, kernel-2.4.22-1.2115.nptl

How reproducible:
Always

Steps to Reproduce:
1. Plug the modem on the USB port
2. service kudzu start
3. Try to make the modem work with a ppp connection


Actual Results:  Kudzu detects the new modem but it doesn't know how to configure it correctly. Generated block on /etc/sysconfig/hwconf:
....
-
class: OTHER
bus: USB
detached: 0
driver: unknown
desc: "LG Electronics Inc. LG CDMA WLL"
usbclass: 0
usbsubclass: 0
usbprotocol: 0
usbbus: 2
usblevel: 1
usbport: 1
usbdev: 2
vendorId: 1004
deviceId: 6800
usbmfr: LG Electronics Inc.
usbprod: LG CDMA WLL
-
.....


class and driver fields are wrong.



Expected Results:  Full plug-and-play functionality

Additional info:

Making 'modprobe acm', dmesg shows a message about ttyACM0 being created, but is not....
I had to create by hand on /dev:

crw-r--r--    1 root     root     166,   0 Dez 19 09:12 ttyACM0


Then I had to configure /etc/wvdial.conf by hand:

[Modem1]
Modem = /dev/ttyACM0
SetVolume = 1
Dial Command = ATDP
Init1 = AT +CRM=1
Baud = 460800
Init3 = ATM1L1
FlowControl = CRTSCTS


The Init1 string looks to be very important. I received it from my broadband provider support people.

And somebody told me to put this in /etc/modules.conf. I think this is irrelevant for this bug, but didn't tested without it:

alias char-major-108 ppp_generic
alias tty-ldisc-3 ppp_async
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate
alias /dev/ppp ppp_generic


After doing that, I was able to normally configure a ppp connection using redhat-config-network.


# cat /proc/bus/usb/devices
....
T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  6 Spd=12  MxCh= 0
D:  Ver= 1.01 Cls=02(comm.) Sub=00 Prot=00 MxPS=16 #Cfgs=  1
P:  Vendor=1004 ProdID=6800 Rev= 0.00
S:  Manufacturer=LG Electronics Inc.
S:  Product=LG CDMA WLL
S:  SerialNumber=Serial Number
C:* #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=02 Prot=01 Driver=acm
E:  Ad=81(I) Atr=03(Int.) MxPS=  16 Ivl=32ms
I:  If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=acm
E:  Ad=8a(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=0b(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
....
Comment 1 Avi Alkalay 2003-12-19 12:40:50 EST
The kernel module that makes it work is acm.o 
Comment 2 Avi Alkalay 2004-05-30 09:59:21 EDT
Upgraded to FC2.
The cdc-acm driver in FC2's original kernel was broken. Works fine 
with kernel-2.6.6-1.383.

But kudzu is still not prepared for this modem.
The dev-3.3.13-1 package creates the device in /dev/input/ttyACM0.

I had to add to /etc/modprobe.conf:

-------------------------------
alias char-major-166 cdc-acm
-------------------------------



I had to create the /etc/wvdial.conf block by hand:

----------------------------
[Modem0]
Modem = /dev/input/ttyACM0
Baud = 460800
SetVolume = 3
Init1 = AT +CRM=1
Init3 = ATM1L3
Dial Command = ATDT
FlowControl = CRTSCTS
----------------------------

The Init1 string is very important. Without it, it doesn't work.

This USB modem works fine.
Comment 3 Matthew Miller 2005-04-26 10:59:54 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 4 Avi Alkalay 2005-04-26 13:07:07 EDT
I tested once on FC3 with some official kernel update and it works now.
I'm currently using this modem with RHEL4 with no problems.

Note You need to log in before you can comment on or make changes to this bug.