Bug 1124363 - New VM Pool dialog is closed after a pool name field validation failure
Summary: New VM Pool dialog is closed after a pool name field validation failure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: 3.6.0
Assignee: Martin Betak
QA Contact: sefi litmanovich
URL:
Whiteboard: virt
: 1139683 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 10:26 UTC by Eli Mesika
Modified: 2016-02-10 19:50 UTC (History)
9 users (show)

Fixed In Version: ovirt-engine-3.6.0-0.0.master.20150412172306.git55ba764
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-04 11:44:14 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 34858 master MERGED frontend: Fix Vm Dialog name validation Never
Red Hat Bugzilla 1139683 None None None Never

Internal Links: 1139683

Description Eli Mesika 2014-07-29 10:26:25 UTC
Description of problem:
New VM Pool dialog is closed after a pool name field validation

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Open the New Pool dialog
2.Enter in the Name field invalid value : for example : z??z??
3.Try to save 

Actual results:
You will get a error message and the dialog is closed

Expected results:
The dialog should stay open after the error message is displayed and give you a chance to fix the name and save all your other settings 

Additional info:

Comment 1 Einav Cohen 2014-09-11 17:01:54 UTC
name uniqueness validation requires a query request to the server (unlike most field validations). this used to be "impossible", but today we already have name uniqueness validation in several dialog - just need to apply the same logic for the New VM Pool dialog as well.

Comment 2 Omer Frenkel 2014-09-21 08:51:41 UTC
might be similar to bug 1139683

Comment 3 Martin Betak 2014-11-06 10:28:00 UTC
*** Bug 1139683 has been marked as a duplicate of this bug. ***

Comment 4 sefi litmanovich 2015-07-23 14:58:55 UTC
Verified with ovirt-engine-3.6.0-0.0.master.20150627185750.git6f063c1.el6.noarch.

Comment 5 Sandro Bonazzola 2015-11-04 11:44:14 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.


Note You need to log in before you can comment on or make changes to this bug.