Bug 1124365 - Anaconda seems to be closed when closed by X button, but it is still running in background
Summary: Anaconda seems to be closed when closed by X button, but it is still running ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Shea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 10:36 UTC by Kamil Páral
Modified: 2014-07-30 10:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 10:09:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 864470 None None None Never

Internal Links: 864470

Description Kamil Páral 2014-07-29 10:36:39 UTC
Description of problem:
If you start anaconda on Live, get to the main hub and then close the window using X button (either in the overview mode, or by using global menu -> Quit), anaconda seems to be closed (to they eyes of a common user), but in fact anaconda process is still running.

If you start anaconda again, *another* process is started. The user thinks he/she simply closed and restarted anaconda, but in fact there are two anaconda processes running. That can potentially cause a lot of problems.

Version-Release number of selected component (if applicable):
Fedora 20 Live GNOME

How reproducible:
always

Steps to Reproduce:
1. boot live
2. start anaconda, go to main hub
3. close the window in the overview mode or using global menu->quit
4. see anaconda process still running
5. start anaconda again from system menu
6. see two anaconda processes running

Expected results:
1. Anaconda should present "Do you really want to quit" dialog if it receives window-close event. The same it does when pressing Quit button on the main hub.
2. Anaconda should not start when another anaconda is running, instead it should inform the user that another anaconda is already running.

Additional info:
This is probably very closely related to bug 864470.

Comment 1 Kamil Páral 2014-07-29 10:38:13 UTC
I have tested just with F20, but I assume there was no change since then, so marking as rawhide.

Comment 2 David Shea 2014-07-29 14:15:30 UTC
I think you will pleasantly surprised by rawhide. Let me know if you see any issues with the behavior in the F21 or rawhide live image.

Comment 3 Kamil Páral 2014-07-30 10:09:04 UTC
I tested with Fedora-Live-Workstation-i686-21-20140727.iso and window closing seems to work well. Instead of silently closing the window, a dialog is displayed asking me whether I really want to quit. Great.

A note: When I ran liveinst in terminal and hit Ctrl+C, the liveinst process was terminated (I returned to the prompt), but anaconda was still running. I would expect Ctrl+C to do nothing (or display the same quit dialog) instead of returning back to the prompt. But that's just a side remark, not that important.

Closing as fixed. Thanks.


Note You need to log in before you can comment on or make changes to this bug.