Bug 1124371 - [gluster] Missing monitoring details tab
Summary: [gluster] Missing monitoring details tab
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: anmol babu
QA Contact: Pavel Stehlik
URL:
Whiteboard: gluster
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 11:18 UTC by Piotr Kliczewski
Modified: 2016-02-10 19:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-23 06:07:11 UTC
oVirt Team: Gluster


Attachments (Terms of Use)
Nagios missing status info (43.77 KB, image/png)
2014-07-29 11:18 UTC, Piotr Kliczewski
no flags Details
Engine log (1.26 MB, application/x-bzip)
2014-07-29 11:18 UTC, Piotr Kliczewski
no flags Details

Description Piotr Kliczewski 2014-07-29 11:18:17 UTC
Created attachment 922109 [details]
Nagios missing status info

Description of problem:


I configured Nagios integration for glusterfs. From Nagios console there is host "Dafault" which is reported to be in good shape. I linked UI plugin as in the doc and I was not able to find monitoring details tab after engine restart,
I do not see anything obvious in the engine logs.


There is minor glitch that host status information used to be:
"OK : None of the Volumes in the cluster are in Critical State "
but when I configured second nagios server it was as in the attached screenshot.


How reproducible:


Steps to Reproduce:
1. Follow http://www.ovirt.org/Features/Nagios_Integration#HOW_TO

Actual results:
No monitoring details tab.

Expected results:
Monitoring details tab should be available on the UI.

Additional info:

Engine installed on f20 and gluster host on rhel6.

Comment 1 Piotr Kliczewski 2014-07-29 11:18:56 UTC
Created attachment 922111 [details]
Engine log

Comment 2 Sahina Bose 2014-07-30 06:02:03 UTC
Anmol, Could you take a look?

Comment 3 anmol babu 2014-07-31 08:22:16 UTC
Sure sahina

Comment 4 anmol babu 2014-08-10 11:49:09 UTC
Hi piotr,
Could you please try and reproduce this issue and share the setup with me.
Because I was able to set the plugin up and running by just following the steps in the wiki.

Comment 5 Piotr Kliczewski 2014-08-27 07:58:25 UTC
Sorry for long reply. Please take a look at this mailing thread:
http://lists.ovirt.org/pipermail/devel/2014-July/008304.html

Comment 6 Sahina Bose 2014-09-23 06:07:11 UTC
Regarding issue of missing status for Default host, Default is a dummy host configured for the cluster. The status information is based on the status of the volumes in the cluster.

Regarding missing monitoring details tab - could not reproduce this issue. 
Hence closing this Works for me.


Note You need to log in before you can comment on or make changes to this bug.