Bug 1124373 - Staypuft: The 'Next', 'Back' & 'Cancel' buttons should stay in the same place
Summary: Staypuft: The 'Next', 'Back' & 'Cancel' buttons should stay in the same place
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-staypuft
Version: Foreman (RHEL 6)
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ga
: Installer
Assignee: Jason E. Rist
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 11:18 UTC by Yogev Rabl
Modified: 2014-08-21 18:06 UTC (History)
5 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.2.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:06:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Yogev Rabl 2014-07-29 11:18:59 UTC
Description of problem:
In the creating a new Openstack Deployment the buttons locations changes in relation to the content of the step's page.
For example the first step's page is longer than the second step's page. In the second step the buttons jumps upwards. 

It would be more comfortable if the buttons will stay always in the same place.

Version-Release number of selected component (if applicable):
ruby193-rubygem-staypuft-0.1.21-1.el6ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a new deployment


Actual results:
The button's location changes in every step

Expected results:
The buttons stay in the same place.

Comment 2 Jason E. Rist 2014-07-29 13:26:19 UTC
Yogev, how do you propose this would work? Would we put all of the pages at the same height? If so, you'd have to scroll, presumably.  What resolution are you working with? Some more context would help.

Comment 3 Liz 2014-07-29 13:29:24 UTC
I'd agree that if a user is looking to just simply review each step and click through the 3 steps this could be annoying. IMO we could accomplish this fix simply by being sure the wizard remains the same height (buttons would be in the same place) for each step. We might need to revisit this in the future if the number of parameters in step 3 grows to be larger than the browser height and the user needs to scroll.

Comment 4 Jason E. Rist 2014-07-29 15:58:14 UTC
Fix here. https://github.com/theforeman/staypuft/pull/243

Comment 5 Yogev Rabl 2014-07-30 07:04:57 UTC
If we place the button at the top of the page instead of the bottom we would not have have the scrolling problem.

Comment 6 Jason E. Rist 2014-07-30 13:50:15 UTC
Yogev, I've asked the UX person that designed this page to comment as well.  For the time being I've made the height of the wizard the same in most cases.

Comment 9 nlevinki 2014-08-07 08:33:50 UTC
In staypuf the buttons are at the bottom right corner in all the pages as expected

Comment 10 errata-xmlrpc 2014-08-21 18:06:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.