Bug 1124378 - Can't sort DCs according to compatibility version
Summary: Can't sort DCs according to compatibility version
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Eli Mesika
QA Contact: Tareq Alayan
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 11:29 UTC by Allon Mureinik
Modified: 2016-02-10 19:34 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0_rc1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:24:07 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30969 master MERGED core: enable to sort DC according to version. Never
oVirt gerrit 30998 ovirt-engine-3.5 MERGED core: enable to sort DC according to version. Never

Description Allon Mureinik 2014-07-29 11:29:51 UTC
Description of problem:
In the Data Center main tab you can sort DCs by all the fields except the compatibility version.

Version-Release number of selected component (if applicable):
[ovirt@localhost ~]$ rpm -qa | grep ovirt-engine
ovirt-engine-lib-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-setup-plugin-websocket-proxy-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-jboss-as-7.1.1-1.el6.x86_64
ovirt-engine-tools-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-websocket-proxy-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-extensions-api-impl-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-restapi-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-backend-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-setup-base-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-userportal-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-cli-3.5.0.2-1.el6.noarch
ovirt-engine-webadmin-portal-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-sdk-python-3.5.0.3-1.el6.noarch
ovirt-engine-dbscripts-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-setup-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Open the Data Centers main tab
2. Click on the "Compatibility Version" header

Actual results:
Nothing happens

Expected results:
Column should sort in ascending order

Additional info:
IIUC, the root cause of this issue is bug 1124375. I'm currently opening both issues and marking this one as blocked by 1124375 so they can both be verified. If you think this is redundant, feel free to close this one as a duplicate.

Comment 1 Eli Mesika 2014-08-03 10:35:25 UTC
Removed BZ dependency since bugs are not related

Comment 2 Tareq Alayan 2014-08-07 11:52:53 UTC
verified
ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

Comment 3 Sandro Bonazzola 2014-10-17 12:24:07 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.