Bug 1124385 - Missing ipappend from default PXE template
Summary: Missing ipappend from default PXE template
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning Templates
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Dominic Cleal
QA Contact: Peter Ondrejka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2014-07-29 11:41 UTC by Ade Bradshaw
Modified: 2017-08-01 20:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 20:34:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6834 None None None 2016-04-22 16:16:32 UTC

Description Ade Bradshaw 2014-07-29 11:41:16 UTC
Description of problem:
When creating a default PXE menu, there is a missing option "ipappend 2"

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Click "Build PXE default"
2. Examine  /var/lib/tftpboot/pxelinux.cfg/default
3. Note the missing "ipappend 2"

Actual results:
ipappend 2 is missing

Expected results:
ipappend is there

Additional info:
--- PXELinux_default.erb.old    2014-07-29 10:15:00.486191538 +0000

+++ PXELinux_default.erb        2014-07-29 10:15:09.430191532 +0000

@@ -23,6 +23,7 @@

<% case profile[:hostgroup].operatingsystem.pxe_type -%>

<% when 'kickstart' -%>

      append initrd=<%= profile[:hostgroup].operatingsystem.initrd(profile[:hostgroup].architecture) %> ks=<%= default_template_url(profile[:template], profile[:hostgroup]) %> ksdevice=bootif network kssendmac

+     ipappend 2

<% when 'preseed' -%>

      append initrd=<%= profile[:hostgroup].operatingsystem.initrd(profile[:hostgroup].architecture) %> interface=auto url=<%= default_template_url(profile[:template], profile[:hostgroup]) %> ramdisk_size=10800 root=/dev/rd/0 rw auto hostname=unassigned-hostname locale=en_US console-setup/ask_detect=false console-setup/layout=USA console-setup/variant=USA

<% end -%>

Comment 1 RHEL Product and Program Management 2014-07-29 11:43:34 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-07-30 09:43:20 UTC
Created redmine issue http://projects.theforeman.org/issues/6834 from this bug

Comment 4 Peter Vreman 2015-07-20 14:50:52 UTC
Still open for Sat6.1.0

# grep -i ipappend /usr/share/foreman/app/views/unattended/pxe/PXELinux_default.erb
# echo $?
1

Comment 5 Bryan Kearney 2015-08-25 17:59:36 UTC
Upstream bug component is Provisioning Templates

Comment 6 Peter Ondrejka 2017-02-10 13:48:30 UTC
On Satellite 6.2.8-1.0:

~]# grep -i ipappend /usr/share/foreman/app/views/unattended/pxe/PXELinux_default.erb
     IPAPPEND 2

~]# grep -i ipappend /var/lib/tftpboot/pxelinux.cfg/default
IPAPPEND 2

Comment 7 Peter Vreman 2017-02-14 09:47:09 UTC
Sorry, this is not Closed the grep check is wrong. It matched the 'discovery' menu item and not the other menu items:

See below the default .erb from 6.2.7 that has 2 LABELs, only the first LABEL entry has the IPAPPEND, the second with the profiles for-loop is still missing it:

----
<%#
kind: PXELinux
name: PXELinux global default
%>

<%# This template has special name (do not change it) and it is used for booting unknown hosts. %>

DEFAULT menu
PROMPT 0
MENU TITLE PXE Menu
TIMEOUT 200
TOTALTIMEOUT 6000
ONTIMEOUT local

LABEL local
     MENU LABEL (local)
     MENU DEFAULT
     LOCALBOOT 0

LABEL discovery
     MENU LABEL (discovery)
     KERNEL boot/fdi-image-rhel_7-vmlinuz
     APPEND initrd=boot/fdi-image-rhel_7-img rootflags=loop root=live:/fdi.iso rootfstype=auto ro rd.live.image acpi=force rd.luks=0 rd.md=0 rd.dm=0 rd.lvm=0 rd.bootif=0 rd.neednet=0 nomodeset proxy.url=https://SATELLITE_CAPSULE_URL:9090 proxy.type=proxy
     IPAPPEND 2

<% for profile in @profiles -%>
LABEL <%= "#{profile[:template]} - #{profile[:hostgroup]}" %>
     KERNEL <%= profile[:hostgroup].operatingsystem.kernel(profile[:hostgroup].architecture) %>
<% case profile[:hostgroup].operatingsystem.pxe_type -%>
<% when 'kickstart' -%>
     APPEND initrd=<%= profile[:hostgroup].operatingsystem.initrd(profile[:hostgroup].architecture) %> ks=<%= default_template_url(profile[:template], profile[:hostgroup]) %> ksdevice=bootif network kssendmac
<% when 'preseed' -%>
     APPEND initrd=<%= profile[:hostgroup].operatingsystem.initrd(profile[:hostgroup].architecture) %> interface=auto url=<%= default_template_url(profile[:template], profile[:hostgroup]) %> ramdisk_size=10800 root=/dev/rd/0 rw auto hostname=unassigned-hostname locale=<%= profile[:hostgroup].params['lang'] || 'en_US' %> console-setup/ask_detect=false console-setup/layout=USA console-setup/variant=USA
<% end -%>

<% end -%>
---

Comment 8 Bryan Kearney 2017-02-14 14:13:21 UTC
Peter O, can please check what Peter V is saying in comment 7? Thanks!

Comment 9 Peter Ondrejka 2017-02-14 14:32:15 UTC
Sorry about premature closing, yes the problem as described in comment #7 persists in 6.8

Comment 10 Bryan Kearney 2017-08-01 20:34:41 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.