Bug 112443 - Tried to repair RPM database, but "rpm -qa" segfaults
Summary: Tried to repair RPM database, but "rpm -qa" segfaults
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 1
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-19 18:52 UTC by Alfredo Milani Comparetti
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-19 18:58:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Result of RPM -QA (4.68 KB, text/plain)
2003-12-19 18:53 UTC, Alfredo Milani Comparetti
no flags Details

Description Alfredo Milani Comparetti 2003-12-19 18:52:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
I tried to repair the RPM database according to 
http://www.rpm.org/hintskinks/repairdb/, but I get a segfault when 
issuing a "rpm -qa".
According to what's written on that URL, I'm posting here my findings.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -qa

Additional info:

Comment 1 Alfredo Milani Comparetti 2003-12-19 18:53:45 UTC
Created attachment 96640 [details]
Result of RPM -QA

Comment 2 Jeff Johnson 2003-12-19 18:58:11 UTC
Try
    rm -f /var/lib/rpm/__db*
    rm -f /var/lib/rpm/Pubkeys
    rpm --rebuilddb -vv
    rpm -qa

If there is no segfault after the above, then
this problem is fixed in rpm-4.2.2-0.5 in fedoral devel.

Otherwise reopen this bug, and I'll get you sorted out.

Comment 3 Alfredo Milani Comparetti 2003-12-19 19:55:00 UTC
That fixed the problem. I'm trying to update the whole system by 
adding the DEVELOPMENT repository to YUM. I guess it will take quite 
a lot of time because of dependencies :-)
Anyway: thank you!


Note You need to log in before you can comment on or make changes to this bug.