Bug 1124441 - Upgrading openjdk causes candlepin to fail
Summary: Upgrading openjdk causes candlepin to fail
Keywords:
Status: CLOSED DUPLICATE of bug 1010111
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2014-07-29 13:38 UTC by Nick Strugnell
Modified: 2014-07-31 13:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 13:50:22 UTC


Attachments (Terms of Use)

Description Nick Strugnell 2014-07-29 13:38:55 UTC
Description of problem:
Upgrading java-1.6.0-openjdk causes candlepin to start failing with errors.

Version-Release number of selected component (if applicable):
candlepin-0.9.19-1.el6_5.noarch

Upgraded java-1.6.0-openjdk from 1.6.0.0-5.1.13.3.el6_5 to 1.6.0.0-6.1.13.4.el6_5



How reproducible:
not tried


Steps to Reproduce:
1. Build RHEL6.5 standard server
2. Deploy Sat 6 beta
3. yum update to latest openjdk

Actual results:
Candlepin stops working, Excerpt from /var/log/foreman/production.log:

Katello::Resources::Candlepin::Owner::Server broke connection (POST /candlepin/owners/Hilti/imports)



Expected results:


Additional info:
Fixed by reboot

Comment 1 RHEL Product and Program Management 2014-07-29 14:04:10 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Mike McCune 2014-07-31 13:50:22 UTC

*** This bug has been marked as a duplicate of bug 1010111 ***


Note You need to log in before you can comment on or make changes to this bug.