Bug 1124442 - jsonrpc: It should be possible to edit host "advanced" parameters to change rpc
Summary: jsonrpc: It should be possible to edit host "advanced" parameters to change rpc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Piotr Kliczewski
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 13:44 UTC by Antoni Segura Puimedon
Modified: 2016-02-10 19:30 UTC (History)
8 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:23:40 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31242 master MERGED core: edit host "advanced" parameters to change protocol Never
oVirt gerrit 32043 ovirt-engine-3.5 MERGED core: edit host "advanced" parameters to change protocol Never

Description Antoni Segura Puimedon 2014-07-29 13:44:01 UTC
Description of problem:
When upgrading an oVirt setup to 3.5, one of the features that one would like
to setup is the new JSON RPC.

The problem is that once the default cluster has been moved to 3.5
compatibility and the vdsm on the hosts are 4.16.1-0.gita4d9abf, if I put the
hosts in maintenance, going to the "advanced" section of the host editing
dialog does not let me change the communication to jsonrpc

Version-Release number of selected component (if applicable):

vdsm-4.16.1-0.gita4d9abf,
ovirt-engine-3.5.0-0.0.master.20140722232056.git8e1babc.fc19.noarch

How reproducible: 100%


Steps to Reproduce:
0. Put the host in maintenance
1. Upgrade setup from 3.4 to 3.5 (both engine and vdsm machines)
2. Go to the Host edit dialog
3. Tick "advanced parameters"

Actual results:
No possibility to change to json rpc for communication with the host


Expected results:
The same options to set the connectivity to use JSON rpc as when adding a new
host are present


Additional info:
The workaround is to delete the host and add it again, but it is very
cumbersome.

Comment 1 Petr Beňas 2014-09-16 14:02:46 UTC
in vt3.1

Comment 2 Sandro Bonazzola 2014-10-17 12:23:40 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.