Bug 1124451 - vdsm leaks memory
Summary: vdsm leaks memory
Keywords:
Status: CLOSED DUPLICATE of bug 1130045
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.6.0
Assignee: Dima Kuznetsov
QA Contact: Gil Klein
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 14:08 UTC by Antoni Segura Puimedon
Modified: 2016-02-10 19:32 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-27 12:33:04 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Antoni Segura Puimedon 2014-07-29 14:08:58 UTC
Description of problem:
When running vdsm for several days with two VMs (2048Mb RAM each), the amount
of used ram in the host system is 85%. The, as part of the upgrade to 3.5
vdsm was restarted and the host system used memory is now only 32%. This seems
to indicate that vdsm leaks some significant amount of memory.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Add to a host with 8Gb of RAM two VMs with el6 guests at 2Gb of RAM each
2. do some busy work on the VMs, reboot them, etc
3. Wait about 10-15 days
4. Check the free memory on the host
5. systemctl stop vdsmd
6. systemctl stop supervdsmd
7. systemctl start vdsmd
8. Check now the free memory on the host

Actual results:
The free memory of the host was just 15%
The free memory of the host is 68%


Expected results:
Both levels are really, really close (with some allowed distance for GC)

Additional info:

Comment 1 Dan Kenigsberg 2014-08-27 12:33:04 UTC
Oops, no need to handle this issue twice.

*** This bug has been marked as a duplicate of bug 1130045 ***


Note You need to log in before you can comment on or make changes to this bug.