Bug 1124458 - User is not deleted from users_details_history table after it was deleted from engine db
Summary: User is not deleted from users_details_history table after it was deleted fro...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-dwh
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Shirly Radco
QA Contact: movciari
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 14:21 UTC by Eli Mesika
Modified: 2016-02-10 19:33 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5 rc2 ovirt-engine-dwh-3.5.0-0.7.fc19.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:44:01 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31044 master MERGED history: fixed etl-update users delete date Never

Description Eli Mesika 2014-07-29 14:21:09 UTC
Description of problem:
User is not deleted from users_details_history db after it was deleted from engine db

Version-Release number of selected component (if applicable):


How reproducible:

Have a setup with oVirt and oVirt DWH

Steps to Reproduce:
1.Add a AD domain using engine-manage-domains
2.Add a new user from AD
3.User is synced to the users_details_history table in DWH DB
4.Remove the user you had added in 2)


Actual results:
User is removed from engine users table but is not deleted from DWH users_details_history table

Expected results:
User should be deleted from users_details_history DWH after it was removed from the users engine table 

Additional info:

Comment 1 Yaniv Lavi 2014-07-29 14:54:20 UTC
This is by design if the user gets a delete date after deletion.




Yaniv

Comment 2 Eli Mesika 2014-07-30 07:24:42 UTC
This is what I have got on the DWH side after deletion :

ovirt_engine_history=# select * from users_details_history;
-[ RECORD 1 ]---+-------------------------------------
user_id         | 518f2d93-ab2d-42a4-af41-f7295d3c97f5
first_name      | yair_group_member2
last_name       | 
domain          | qa.lab.tlv.redhat.com
username        | yair_group_member2
department      | 
user_role_title | 
email           | 
external_id     | 0814faaf-5f98-4ab8-8e1b-e38de16f0fdd
active          | t
create_date     | 2014-07-29 17:11:35.31+03
update_date     | 
delete_date     | 
-[ RECORD 2 ]---+-------------------------------------
user_id         | fdfc627c-d875-11e0-90f0-83df133b58cc
first_name      | admin
last_name       | 
domain          | internal
username        | admin
department      | 
user_role_title | 
email           | 
external_id     | fdfc627c-d875-11e0-90f0-83df133b58cc
active          | t
create_date     | 2014-07-29 10:53:35.471+03
update_date     | 2014-07-29 17:06:18.305+03
delete_date     | 


I expect to get at least the delete_date for the 1st record

Comment 3 movciari 2014-09-08 15:23:15 UTC
tested on vt2.2, delete date was set correctly after user was deleted from engine

Comment 4 Sandro Bonazzola 2014-10-17 12:44:01 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.