Bug 1124473 - yum reports filesystem has a file conflict with previous version of itself
Summary: yum reports filesystem has a file conflict with previous version of itself
Keywords:
Status: CLOSED DUPLICATE of bug 447156
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 14:44 UTC by Bruno Wolff III
Modified: 2014-07-30 10:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 10:41:11 UTC


Attachments (Terms of Use)
yum output (1.87 KB, text/plain)
2014-07-29 14:44 UTC, Bruno Wolff III
no flags Details

Description Bruno Wolff III 2014-07-29 14:44:55 UTC
Created attachment 922171 [details]
yum output

Description of problem:
When updating the filesystem package a conflict is reported with a previous version of itself, which doesn't make sense since the old version is being removed.

Version-Release number of selected component (if applicable):
yum-3.4.3-152.fc21

Comment 1 Bruno Wolff III 2014-07-29 14:50:07 UTC
dnf has the same problem, so there may be a problem with some of the backend stuff.

Comment 2 Bruno Wolff III 2014-07-29 14:53:00 UTC
rpm has the same problem so I am moving this to rpm.

[root@bruno f]# rpm -Uvh filesystem-3.2-28.fc22.i686.rpm
Preparing...                          ################################# [100%]
	file /media from install of filesystem-3.2-28.fc22.i686 conflicts with file from package filesystem-3.2-27.fc22.i686

Comment 3 Ľuboš Kardoš 2014-07-30 10:41:11 UTC
The problem is that directory /media changed to symlink to /run/media. This change was done because of bug 965918. For problem changing directory to symlink a bug already exits (bug 447156).

*** This bug has been marked as a duplicate of bug 447156 ***


Note You need to log in before you can comment on or make changes to this bug.