Bug 1124474 - [RFE] Provisioning/booting own images
Summary: [RFE] Provisioning/booting own images
Keywords:
Status: CLOSED DUPLICATE of bug 911515
Alias: None
Product: Beaker
Classification: Community
Component: general
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 14:46 UTC by Jaromír Cápík
Modified: 2018-02-06 00:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 06:03:28 UTC


Attachments (Terms of Use)

Description Jaromír Cápík 2014-07-29 14:46:56 UTC
The current solution doesn't allow users to provision/boot their own images and makes them fully dependent on what's served. This makes the whole solution inflexible. It isn't easily possible to debug/fix installer problems without waiting for the next compose. In case of globalsync failures the provision list becomes empty or containing just broken/unbootable images. People should be able to use this new option as a last resort if such problems occur. The system would still be usable till the syncing problem is fixed by responsible people (and that might take few days).
I currently own 5 unbootable servers and have no chance to fix them as I have no rights to upload/import my own images. I consider that a big flaw of the whole process.
Please, ADD an option for provisioning/booting own images.

Comment 3 Nick Coghlan 2014-07-30 11:07:12 UTC
beaker-import already allows importing arbitrary distros, under the control of the local lab operations team. This can be done independently of any centralised build process.

However, the beaker-import command currently isn't covered in the online documentation - it only has local help on the lab controller.

A man page was written as part of updates to the beaker-import command for bug 958590 (which has been postponed for the time being):

http://gerrit.beaker-project.org/#/c/2526/1/documentation/admin-guide/man/beaker-import.rst

Dan, perhaps we should split that project in two, and cover properly documenting the status quo under this bug, and then treat bug 958590 as an enhancement on top of that?

Comment 8 Dan Callaghan 2014-08-04 00:33:23 UTC
Yeah this sounds like it is just a dupe of bug 911515 -- ability to tell Beaker in your recipe "skip the distro library, just use the distro tree from this URL I am giving you".

Comment 9 Nick Coghlan 2014-08-12 05:55:31 UTC
As bug 1108455 points out in the context of image based provisioning, it's also possible to experiment with this for *guest* recipes by using a custom installation task (perhaps derived from virt/install).

Comment 10 Nick Coghlan 2014-08-12 06:03:28 UTC
As Dan suggested, flagging this as a dupe of 911515. I've transferred Bill's suggestion over to that RFE, and noted some of the other things that would need to be taken into account.

*** This bug has been marked as a duplicate of bug 911515 ***


Note You need to log in before you can comment on or make changes to this bug.