Bug 1124494 - Force user entered nic names to lower case
Summary: Force user entered nic names to lower case
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: Foreman (RHEL 6)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ga
: Installer
Assignee: Scott Seago
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1184666
TreeView+ depends on / blocked
 
Reported: 2014-07-29 15:44 UTC by Mike Burns
Modified: 2015-01-22 00:24 UTC (History)
6 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.2.1.el6ost
Doc Type: Release Note
Doc Text:
In previous releases, users were advised to enter only lower-case NIC names during deployment to avoid any issues. This is no longer required, as all NIC names are now checked as lower-case. For example, 'Eth0' and 'ETH0' will both be evaluated as 'eth0'.
Clone Of:
: 1184666 (view as bug list)
Environment:
Last Closed: 2014-08-21 18:06:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Mike Burns 2014-07-29 15:44:49 UTC
Description of problem:
We currently don't force all nic names to lower case.  This could cause future problems if a user enters ETH0 instead of eth0

At the moment, any issues are unconfirmed.

Comment 2 Mike Burns 2014-08-05 18:32:39 UTC
Scott, can you add a quick tolower (or the ruby equivalent) on the nic fields?

Comment 3 Scott Seago 2014-08-06 16:34:30 UTC
https://github.com/theforeman/staypuft/pull/257

Comment 5 Alexander Chuzhoy 2014-08-12 15:27:04 UTC
Verified: rhel-osp-installer-0.1.9-1.el6ost.noarch


In the advanced configuration of the deployment, checking the Ovs tunnel iface - I see that it evaluates to the lower case of what I entered in upper case.

Comment 7 errata-xmlrpc 2014-08-21 18:06:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.