Bug 1124508 - domblkinfo command fails with EBADF with rbd
Summary: domblkinfo command fails with EBADF with rbd
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1319075
TreeView+ depends on / blocked
 
Reported: 2014-07-29 16:23 UTC by Sage Weil
Modified: 2019-09-12 07:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-10 19:12:09 UTC


Attachments (Terms of Use)

Description Sage Weil 2014-07-29 16:23:40 UTC
Description of problem:

Found that the 'domblkinfo' command fails while 'domblklist' and 'domblkstat' commands function normally.

Environment:
OpenStack Havana
Ubuntu 12.04 LTS

rbd volume


Version-Release number of selected component (if applicable):

0.9.8-2ubuntu1

How reproducible:

Always

Steps to Reproduce:

Example output:
~# virsh domblklist instance-00002d07
Target Source
------------------------------------------------
vda rtp1-1-csx-cinder-volume-1/volume-01bae4ef-d270-4e07-93cb-c98cf66bd9c1
~# virsh domblkstat instance-00002d07 vda
vda rd_req 6107
vda rd_bytes 131831808
vda wr_req 25024
vda wr_bytes 121126912
vda flush_operations 12192
vda rd_total_times 10100179441
vda wr_total_times 10211260028
vda flush_total_times 79084523929

~# virsh domblkinfo instance-00002d07 vda
error: cannot stat file 'rtp1-1-csx-cinder-volume-1/volume-01bae4ef-d270-4e07-93cb-c98cf66bd9c1': Bad file descriptor

Actual results:


Expected results:


Additional info:

Here is the original report in the ceph bug tracker:

 http://tracker.ceph.com/issues/7693

Comment 1 Cole Robinson 2016-04-10 19:12:09 UTC
Sorry this didn't receive a timely response. The referenced libvirt version 0.9.8 is 4.5 years old, and that's an ubuntu package anyways so there isn't much we can do here. The rbd driver has seen a lot of change in libvirt too so the bug may be fixed.

Closing as DEFERRED... but Justin, Chris, since you guys attached other reports to this bug, if someone is hitting this with recent RHEL, please re-open and change the bug product to the relevant RHEL release, and give updated libvirt versions and reproducer info

Comment 2 Vikhyat Umrao 2017-01-10 16:44:35 UTC
# virsh list
 Id    Name                           State
----------------------------------------------------
 5     instance-00000087              running

# virsh domblklist instance-00000087
Target     Source
------------------------------------------------
vda        volumes/volume-4ed9a541-c7bf-41fc-8093-4d687ee1b2e2

# virsh domblkinfo instance-00000087 vda
Capacity:       18253611008
Allocation:     17739656704
Physical:       18253611008

It works fine in Red Hat Enterprise Linux 7.3.
libvirt-client-2.0.0-10.el7.x86_64


Note You need to log in before you can comment on or make changes to this bug.