Bug 1124524 - Immediately publishing an existing content view that was published does not increment the version number
Summary: Immediately publishing an existing content view that was published does not i...
Keywords:
Status: CLOSED DUPLICATE of bug 1104175
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 17:22 UTC by Og Maciel
Modified: 2014-08-05 16:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-05 16:28:04 UTC


Attachments (Terms of Use)
Version 2 was published but new form is giving me version 2 again. (91.08 KB, image/png)
2014-07-29 17:22 UTC, Og Maciel
no flags Details

Description Og Maciel 2014-07-29 17:22:45 UTC
Created attachment 922239 [details]
Version 2 was published but new form is giving me version 2 again.

Description of problem:

Having gone through the process of publishing and promoting my content view, I noticed that if I immediately try to re-publish it, the next version (which is automatically incremented in the UI) was still showing the value from the version that was previously published.

The (attached) screenshot shows that even though Version 2 was just published, the web ui form is giving me the same exact version (2) for the next version. 

Version-Release number of selected component (if applicable):

Environment:
* Build: Satellite-6.0.4-RHEL-6-20140723.0

Packages:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.32-1.el6sat.noarch
* foreman-compute-1.6.0.32-1.el6sat.noarch
* foreman-gce-1.6.0.32-1.el6sat.noarch
* foreman-libvirt-1.6.0.32-1.el6sat.noarch
* foreman-ovirt-1.6.0.32-1.el6sat.noarch
* foreman-postgresql-1.6.0.32-1.el6sat.noarch
* foreman-proxy-1.6.0.22-1.el6sat.noarch
* foreman-selinux-1.6.0.3-1.el6sat.noarch
* foreman-vmware-1.6.0.32-1.el6sat.noarch
* katello-1.5.0-27.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.56-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* rubygem-hammer_cli-0.1.1-10.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.1-13.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-3.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.4-9.el6sat.noarch

How reproducible:


Steps to Reproduce:
1. Publish a content view
2. Promote it to the next lifecycle
3. Without closing any UI notifications that may have popped up, re-publish the content view

Actual results:

The Version value in the UI is not automatically incremented

Expected results:


Additional info:

Comment 2 Og Maciel 2014-07-29 17:43:09 UTC
Just for fun I decided to proceed with the content view promotion (even though the UI gave me a version that had already been used) and the UI shows that once the publish action starts, the correctly incremented version was used.

Comment 3 Brad Buckingham 2014-08-05 16:28:04 UTC

*** This bug has been marked as a duplicate of bug 1104175 ***


Note You need to log in before you can comment on or make changes to this bug.