Bug 1124545 - Rubygem-Staypuft: Running rhel-osp-installer --provisioning-wizard non-interactive crashes.
Summary: Rubygem-Staypuft: Running rhel-osp-installer --provisioning-wizard non-inter...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: Foreman (RHEL 6)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Installer
Assignee: Brad P. Crochet
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 18:28 UTC by Alexander Chuzhoy
Modified: 2014-08-21 18:06 UTC (History)
10 users (show)

Fixed In Version: rhel-osp-installer-0.1.8-1.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, the provisioning wizard did not properly save the values for skipping subscription seeding or provisioning repositories. As a result, when running the provisioning wizard in the non-interactive mode without the values, the wizard would throw an 'Unprocessable Entity' stacktrace. With this fix, you can update the answer file according to the following steps: 1. Add the following values to the :custom: section on the answer file: :skip_subscription_seeding: (true|false) :skip_repo_path: (true|false) 2. Save the answer file properly and retrieve these values from the provisioning wizard when run interactively. As a result, the provisioning wizard will no longer throw an error.
Clone Of:
Environment:
Last Closed: 2014-08-21 18:06:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Alexander Chuzhoy 2014-07-29 18:28:25 UTC
Rubygem-Staypuft:  Running rhel-osp-installer --provisioning-wizard non-interactive crashes.

Environment:
rhel-osp-installer-0.1.6-4.el6ost.noarch
openstack-foreman-installer-2.0.16-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-19.8.el6ost.noarch

Steps to reproduce:
1. Install rhel-osp-installer.
2. Copy the answer files to /etc/foreman/ directory.
3. Run:  rhel-osp-installer --provisioning-wizard non-interactive

Result:

[root@staypuft ~]# rhel-osp-installer --provisioning-wizard non-interactive
Installing             Done                                               [100%] [.................................................................................................................................]
Starting configuration...                                                                                                                                                                                           
Warning: Sections other than main, master, agent, user are deprecated in puppet.conf. Please use the directory environments feature to specify environments. (See http://docs.puppetlabs.com/puppet/latest/reference/environments.html)                                                                                                                                                                                                   
   (at /usr/lib/ruby/site_ruby/1.8/puppet/settings/config_file.rb:77:in `collect')                                                                                                                                   
/usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/abstract_response.rb:48:in `return!': 422 Unprocessable Entity (RestClient::UnprocessableEntity)                                                        
        from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:220:in `process_result'                                                                                                         
        from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:169:in `transmit'                                                                                                               
        from /usr/lib/ruby/1.8/net/http.rb:543:in `start'                                                                                                                                                            
        from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:166:in `transmit'                                                                                                               
        from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:60:in `execute'                                                                                                                 
        from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:31:in `execute'                                                                                                                 
        from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/resource.rb:63:in `post'                                                                                                                   
        from /usr/lib/ruby/gems/1.8/gems/foreman_api-0.1.11/lib/foreman_api/base.rb:79:in `send'                                                                                                                     
        from /usr/lib/ruby/gems/1.8/gems/foreman_api-0.1.11/lib/foreman_api/base.rb:79:in `http_call'                                                                                                                
        from /usr/lib/ruby/gems/1.8/gems/foreman_api-0.1.11/lib/foreman_api/base.rb:62:in `perform_call'                                                                                                             
        from /usr/lib/ruby/gems/1.8/gems/foreman_api-0.1.11/lib/foreman_api/resources/parameter.rb:54:in `create'                                                                                                    
        from /usr/share/foreman-installer/hooks/lib/foreman.rb:73:in `show_or_ensure'                                                                                                                                
        from /usr/share/foreman-installer/hooks/lib/subscription_seeder.rb:75:in `seed'                                                                                                                              
        from /usr/share/foreman-installer/hooks/lib/subscription_seeder.rb:69:in `each'                                                                                                                              
        from /usr/share/foreman-installer/hooks/lib/subscription_seeder.rb:69:in `seed'                                                                                                                              
        from /usr/share/foreman-installer/hooks/post/10-setup_provisioning.rb:25:in `load'                                                                                                                           
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hook_context.rb:13:in `instance_exec'                                                                                                                   
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hook_context.rb:13:in `execute'                                                                                                                         
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:48:in `execute'                                                                                                                              
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:47:in `each_pair'                                                                                                                            
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:47:in `execute'                                                                                                                              
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:339:in `run_installation'                                                                                                             
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/exit_handler.rb:24:in `call'                                                                                                                            
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/exit_handler.rb:24:in `exit'                                                                                                                            
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:122:in `exit'                                                                                                                         
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:338:in `run_installation'                                                                                                             
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:109:in `execute'                                                                                                                      
        from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'                                                                                                                                
        from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'                                                                                                                               
        from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:116:in `run'                                                                                                                          
        from /usr/sbin/rhel-osp-installer:54   



Expected result:
Completed installation.

Note: Rerunning the installation without argument works fine - doesn't crash.

Comment 2 Brad P. Crochet 2014-07-30 18:44:26 UTC
I am unable to reproduce this. Can you attach your answer file(s)?

Comment 5 Brad P. Crochet 2014-07-30 20:58:54 UTC
PR submitted upstream:

https://github.com/theforeman/foreman-installer-staypuft/pull/58

Comment 6 Brad P. Crochet 2014-07-30 21:01:08 UTC
The values are missing from rhel-osp-installer.yaml

:skip_subscription_seeding: (true|false)
:skip_repo_path: (true|false)

These go in the :custom: section. Without these, if the repo is not specified, or the subscription manager credentials are not specified, non-interactive mode will fail. The above PR writes those values to the answer file so that the choice made in interactive mode will persist.

Comment 10 Omri Hochman 2014-08-10 12:00:44 UTC
Failed QA 
(rhel-osp-installer-0.1.9-1.el6ost.noarch)  with the same exception : 



[root@staypuft ~]# rhel-osp-installer --provisioning-wizard non-interactive
Installing             Done                                               [100%] [..........................................................................]
Starting configuration...
Warning: Sections other than main, master, agent, user are deprecated in puppet.conf. Please use the directory environments feature to specify environments. (See http://docs.puppetlabs.com/puppet/latest/reference/environments.html)
   (at /usr/lib/ruby/site_ruby/1.8/puppet/settings/config_file.rb:77:in `collect')
/usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/abstract_response.rb:48:in `return!': 422 Unprocessable Entity (RestClient::UnprocessableEntity)
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:220:in `process_result'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:169:in `transmit'
	from /usr/lib/ruby/1.8/net/http.rb:543:in `start'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:166:in `transmit'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:60:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:31:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/resource.rb:63:in `post'
	from /usr/lib/ruby/gems/1.8/gems/foreman_api-0.1.11/lib/foreman_api/base.rb:79:in `send'
	from /usr/lib/ruby/gems/1.8/gems/foreman_api-0.1.11/lib/foreman_api/base.rb:79:in `http_call'
	from /usr/lib/ruby/gems/1.8/gems/foreman_api-0.1.11/lib/foreman_api/base.rb:62:in `perform_call'
	from /usr/lib/ruby/gems/1.8/gems/foreman_api-0.1.11/lib/foreman_api/resources/parameter.rb:54:in `create'
	from /usr/share/foreman-installer/hooks/lib/foreman.rb:73:in `show_or_ensure'
	from /usr/share/foreman-installer/hooks/lib/subscription_seeder.rb:85:in `seed'
	from /usr/share/foreman-installer/hooks/lib/subscription_seeder.rb:79:in `each'
	from /usr/share/foreman-installer/hooks/lib/subscription_seeder.rb:79:in `seed'
	from /usr/share/foreman-installer/hooks/post/10-setup_provisioning.rb:25:in `load'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hook_context.rb:13:in `instance_exec'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hook_context.rb:13:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:48:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:47:in `each_pair'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:47:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:339:in `run_installation'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/exit_handler.rb:24:in `call'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/exit_handler.rb:24:in `exit'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:122:in `exit'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:338:in `run_installation'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:109:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
	from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:116:in `run'
	from /usr/sbin/rhel-osp-installer:54

Comment 11 Omri Hochman 2014-08-10 12:11:33 UTC
Verified with (rhel-osp-installer-0.1.9-1.el6ost.noarch)  - The Issue from comment #1- was probably due to bad answer-file .

[root@staypuft foreman]# rhel-osp-installer --provisioning-wizard non-interactive
Installing             Done                                               [100%] [..........................................................................]
Starting configuration...
Warning: Sections other than main, master, agent, user are deprecated in puppet.conf. Please use the directory environments feature to specify environments. (See http://docs.puppetlabs.com/puppet/latest/reference/environments.html)
   (at /usr/lib/ruby/site_ruby/1.8/puppet/settings/config_file.rb:77:in `collect')
Starting to seed provisioning data
Use 'base_RedHat_7' hostgroup for provisioning
  Success!
  * Foreman is running at https://staypuft.example.com
      Default credentials are 'admin:changeme'
  * Foreman Proxy is running at https://staypuft.example.com:8443
  * Puppetmaster is running at port 8140
  The full log is at /var/log/rhel-osp-installer/rhel-osp-installer.log

Comment 12 errata-xmlrpc 2014-08-21 18:06:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.