Bug 1124549 - hammer: confusing error message on trying to create a product with an already existing label
Summary: hammer: confusing error message on trying to create a product with an already...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 18:43 UTC by sthirugn@redhat.com
Modified: 2019-04-01 20:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:30:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11589 None None None 2016-04-22 15:33:52 UTC
Red Hat Bugzilla 1105061 None None None Never

Internal Links: 1105061

Description sthirugn@redhat.com 2014-07-29 18:43:41 UTC
Description of problem:
hammer: confusing error message on trying to create a product with an already existing label

Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140723.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.29-1.el6sat.noarch
* foreman-compute-1.6.0.29-1.el6sat.noarch
* foreman-gce-1.6.0.29-1.el6sat.noarch
* foreman-libvirt-1.6.0.29-1.el6sat.noarch
* foreman-ovirt-1.6.0.29-1.el6sat.noarch
* foreman-postgresql-1.6.0.29-1.el6sat.noarch
* foreman-proxy-1.6.0.21-1.el6sat.noarch
* foreman-selinux-1.6.0-8.el6sat.noarch
* foreman-vmware-1.6.0.29-1.el6sat.noarch
* katello-1.5.0-27.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.56-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
hammer> product create --organization-id=3 --name newproduct1 --label unique
Product created

hammer> product create --organization-id=3 --name newproduct2 --label unique
Could not create the product:
  Validation failed: Label Product with label 'unique' already exists in this organization.

Actual results:
Validation failed: Label Product with label 'unique' already exists in this organization.

Expected results:
Validation failed: Product with label 'unique' already exists in this organization.

Additional info:

Comment 2 Brad Buckingham 2015-08-27 17:50:14 UTC
Created redmine issue http://projects.theforeman.org/issues/11589 from this bug

Comment 3 Brad Buckingham 2015-08-27 17:54:35 UTC
Katello PR:
  https://github.com/Katello/katello/pull/5445    

Before:
      Validation failed: Label Product with label 'zoo' already exists in this organization.
    
After:
      Validation failed: Label has already been taken for a product in this organization.

Comment 4 Bryan Kearney 2015-08-27 20:01:20 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11589 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello|5778eefd922674c32947264e7f314d52385107e2.

Comment 5 Jitendra Yejare 2015-09-08 12:01:49 UTC
Verified in Upstream.

Result:
hammer> product create --organization-id=1 --name prod11 --label unique
Product created
hammer> product create --organization-id=1 --name prod21 --label unique
Could not create the product:
  Validation failed: Label has already been taken for a product in this organization.

Version:
foreman-release-scl-1-1.el7.x86_64
foreman-1.10.0-0.develop.201509041547git84f7fc6.el7.noarch

Comment 8 Bryan Kearney 2016-07-27 11:30:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.