Bug 1124553 - [RFE] Hide advanced installer options that are not intended for customer use
Summary: [RFE] Hide advanced installer options that are not intended for customer use
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1265982 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 18:58 UTC by Dave Sullivan
Modified: 2019-07-11 08:05 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-02 17:22:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 10283 None None None 2016-04-26 17:01:03 UTC

Description Dave Sullivan 2014-07-29 18:58:16 UTC
Description of problem:

 katello-installer --certs-log-dir /local1/satellite6/certs  --certs-ssl-build-dir  /local1/satellite6/ssl-build  --foreman-app-root /local1/satellite6/foreman --foreman-puppet-home /local1/satellite6/puppet --katello-config-dir /local1/satellite6/foreman/plugins --katello-log-dir /local1/satellite6/foreman/log/plugins

The first run completely failed and I would have expected the installer to create the directory. The second run went better but still failed after creating /local1/satellite6.



[root@totlx90101 tmp]# katello-installer --certs-log-dir /local1/satellite6/certs  --certs-ssl-build-dir  /local1/satellite6/ssl-build  --foreman-app-root /local1/satellite6/foreman --foreman-puppet-home /local1/satellite6/puppet --katello-config-dir /local1/satellite6/foreman/plugins --katello-log-dir /local1/satellite6/foreman/log/plugins
 Could not set 'file' on ensure: cannot generate tempfile `/local1/satellite6/ssl-build/rhsm-katello-reconfigure20140729-23332-14mpoaz-9' at 20:/usr/share/katello-installer/modules/certs/manifests/katello.pp
 Could not set 'file' on ensure: cannot generate tempfile `/local1/satellite6/ssl-build/rhsm-katello-reconfigure20140729-23332-14mpoaz-9' at 20:/usr/share/katello-installer/modules/certs/manifests/katello.pp
 /Stage[main]/Certs::Katello/File[/local1/satellite6/ssl-build/rhsm-katello-reconfigure]/ensure: change from absent to file failed: Could not set 'file' on ensure: cannot generate tempfile `/local1/satellite6/ssl-build/rhsm-katello-reconfigure20140729-23332-14mpoaz-9' at 20:/usr/share/katello-installer/modules/certs/manifests/katello.pp
 Could not start Service[mongodb]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait mongod start' returned 1: Starting mongod: [  OK  ]
 /Stage[main]/Mongodb::Server::Service/Service[mongodb]/ensure: change from stopped to running failed: Could not start Service[mongodb]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait mongod start' returned 1: Starting mongod: [  OK  ]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: Failed to call refresh: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: Failed to call refresh: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]
Installing             Done                                               [100%] [.....................................................................................]
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/katello-installer/katello-installer.log


Version-Release number of selected component (if applicable):

satellite 6 beta

How reproducible:

See above


Actual results:


Expected results:


Additional info:

Having a separate install directory locations allows for portability

Comment 1 RHEL Product and Program Management 2014-07-29 19:03:42 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Mike McCune 2014-08-26 04:00:49 UTC
WORKAROUND:

Do not specify alternate directories and accept the default options.

Comment 5 Mike McCune 2014-08-26 04:15:12 UTC
WORKAROUND:

Do not specify any of the options that change a deployment directory, this would be any argument ending in -dir.  Do NOT use any of the following options in the installer:

    --certs-log-dir               When the log files should go (default: "/var/log/certs")
    --certs-password-file-dir     The location to store password files (default: "certs::params::password_file_dir")
    --certs-pki-dir               The PKI directory under which to place certs (default: "/etc/pki/katello")
    --certs-ssl-build-dir         The directory where SSL keys, certs and RPMs will be generated (default: "/root/ssl-build")
    --foreman-app-root            Name of foreman root directory (default: "/usr/share/foreman")
    --foreman-puppet-home         Puppet home directory (default: "/var/lib/puppet")
    --katello-config-dir          Location for Katello config files (default: "/etc/foreman/plugins")
    --katello-log-dir             Location for Katello log files to be placed (default: "/var/log/foreman/plugins")

Comment 6 James Hartsock 2014-08-27 21:55:41 UTC
Not sure comment #5 is a "workaround", that is just saying don't use these options which we mention in the --help output.

Comment 8 Dave Sullivan 2015-01-09 21:32:18 UTC
Unclear if this make 6.1 but at a minimum maybe it would make sense to not make these options available.

Comment 9 Dave Sullivan 2015-01-09 21:33:23 UTC
sorry I mean make the option unavailable

Comment 10 Bryan Kearney 2015-04-27 20:21:58 UTC
Created redmine issue http://projects.theforeman.org/issues/10283 from this bug

Comment 11 Bryan Kearney 2016-02-23 15:10:19 UTC
Upstream bug assigned to inecas@redhat.com

Comment 13 Stephen Benjamin 2016-08-23 17:14:37 UTC
Updating title to reflect the goal of this BZ.  There are a LOT of parameters that are advanced, and should not be touched by end users.  Switches customers intended to be used can be shown under the installer's '--help', everything else should get moved as Advanced in the various puppet classes.

BZ1265982 is also included here, the repo management options will also be marked advanced.

This has the added benefit of reducing the size of the --help output significantly (> 33% reduction).

Comment 14 Stephen Benjamin 2016-08-23 17:15:49 UTC
*** Bug 1265982 has been marked as a duplicate of this bug. ***

Comment 15 Bryan Kearney 2016-08-23 18:02:35 UTC
Upstream bug assigned to inecas@redhat.com

Comment 16 Bryan Kearney 2017-05-09 18:00:15 UTC
This did not make the 1.15/3.5 cut. I am pushing this out to sat-backlog.

Comment 17 Bryan Kearney 2017-11-02 17:21:31 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 18 Bryan Kearney 2017-11-02 17:22:06 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.