Bug 1124568 - cscope reports "File does not have expected format" when searching for symbol usage
Summary: cscope reports "File does not have expected format" when searching for symbol...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cscope
Version: 6.7
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Neil Horman
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Depends On: 1087940 1124571
Blocks: 1002711 1172231 1269638 1270066
TreeView+ depends on / blocked
 
Reported: 2014-07-29 20:19 UTC by Jacob Hunt
Modified: 2016-05-11 00:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1087940
Environment:
Last Closed: 2016-05-11 00:25:36 UTC


Attachments (Terms of Use)
patch to fix null string (1.08 KB, patch)
2015-12-16 15:26 UTC, Neil Horman
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0902 normal SHIPPED_LIVE cscope bug fix update 2016-05-10 22:51:00 UTC

Description Jacob Hunt 2014-07-29 20:19:24 UTC
+++ This bug was initially created as a clone of Bug #1087940 +++

Description of problem:
Upstream bug http://sourceforge.net/p/cscope/bugs/200/

cscope reports "File does not have expected format" when performing
a lookup for a C symbol.

This happens for some of the symbols.  On is reported upstream.
I can consistently reproduce by looking for skb_mac_gso_segment
in the kernel source tree.

The index is built using 
 # cscope -q -b -R -k

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Build a symbol db using
   # cscope -q -b -R -k
2. Launch cscope
3. Search for skb_mac_gso_segment C symbol

Actual results:


Expected results:


Additional info:
Upstream bug includes a patch (http://sourceforge.net/p/cscope/bugs/200/#10cf).
I've built a test rpm and verified that the patch solves this problem for me.

--- Additional comment from Fedora Update System on 2014-04-15 10:36:55 MDT ---

cscope-15.8-8.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cscope-15.8-8.fc20

--- Additional comment from Fedora Update System on 2014-04-16 03:26:43 MDT ---

Package cscope-15.8-8.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cscope-15.8-8.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5245/cscope-15.8-8.fc20
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2014-04-24 01:33:26 MDT ---

cscope-15.8-8.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 3 Neil Horman 2015-12-16 15:26:57 UTC
Created attachment 1106481 [details]
patch to fix null string

please test with this patch.  Thanks.

Comment 9 errata-xmlrpc 2016-05-11 00:25:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0902.html


Note You need to log in before you can comment on or make changes to this bug.