Bug 1124577 - Removing a tag from a category displays an error
Summary: Removing a tag from a category displays an error
Keywords:
Status: CLOSED DUPLICATE of bug 1116705
Alias: None
Product: PressGang CCMS
Classification: Community
Component: Web-UI
Version: 1.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: pressgang-ccms-dev
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 20:37 UTC by Matthew Casperson
Modified: 2014-08-04 22:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 22:52:07 UTC


Attachments (Terms of Use)

Description Matthew Casperson 2014-07-29 20:37:50 UTC
When you attempt to remove a tag from a category, the following error is displayed:

An error occurred on the server. Please try again and if this problem persists, please log a bug.

java.lang.IllegalArgumentException: id to load is required for loading

Comment 1 Lee Newson 2014-07-29 22:52:07 UTC
This is caused by changes in BZ#1116705, so going to mark it as a duplicate of that.

The cause of this is that it previously used to use the category id to remove the tag, but I changed it to be part "relationshipId" which isn't set by the UI. As such I'll update the rest server to check if relationshipId exists and if so use that, otherwise use the category id.

*** This bug has been marked as a duplicate of bug 1116705 ***


Note You need to log in before you can comment on or make changes to this bug.