Bug 1124593 - Same cluster appears twice in the clusters table with different info
Summary: Same cluster appears twice in the clusters table with different info
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Daniel Erez
QA Contact: Antonin Pagac
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 21:09 UTC by Nir Soffer
Modified: 2016-02-10 19:34 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0_rc1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:42:08 UTC
oVirt Team: Infra


Attachments (Terms of Use)
Screenshot showing the duplicated cluster (61.91 KB, image/png)
2014-07-29 21:09 UTC, Nir Soffer
no flags Details
Screenshot showing the data-center contents (22.08 KB, image/png)
2014-07-29 21:12 UTC, Nir Soffer
no flags Details
Another example where same cluster appears about 30 times (137.20 KB, image/png)
2014-07-29 21:29 UTC, Nir Soffer
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30841 master MERGED core: fixed search Disks when filtered by data-center Never
oVirt gerrit 30859 ovirt-engine-3.5 MERGED core: fixed search Disks when filtered by data-center Never

Description Nir Soffer 2014-07-29 21:09:46 UTC
Created attachment 922351 [details]
Screenshot showing the duplicated cluster

Description of problem:
Same cluster appears twice in the clusters tab, showing different info.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.5.0-0.0.master.20140722232056.git8e1babc.fc19

How reproducible:
Always

Steps to Reproduce:
1. Select the Cluster tab
2. Select a data center with one cluster on the left pane

This is an improved version of bug 1124584, since there is different info displayed for the duplicated entity, increasing the user confusion.

Comment 1 Nir Soffer 2014-07-29 21:12:13 UTC
Created attachment 922352 [details]
Screenshot showing the data-center contents

Comment 2 Nir Soffer 2014-07-29 21:29:49 UTC
Created attachment 922355 [details]
Another example where same cluster appears about 30 times

Comment 3 Nir Soffer 2014-07-30 13:39:52 UTC
Daniel, do you think this is a duplicate of bug 1124584, and fix by the same patch?

Comment 4 Daniel Erez 2014-07-30 13:55:14 UTC
(In reply to Nir Soffer from comment #3)
> Daniel, do you think this is a duplicate of bug 1124584, and fix by the same
> patch?

Yes, this is also fixed by http://gerrit.ovirt.org/#/c/30841

Comment 5 Antonin Pagac 2014-09-03 12:48:44 UTC
Verified in: oVirt Engine Version: 3.5.0-0.0.master.20140821064931.gitb794d66.el6

Comment 6 Sandro Bonazzola 2014-10-17 12:42:08 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.