Bug 1124595 - "mom.HostMonitor" ending due to non existent /proc/<vm_pid>/stat
Summary: "mom.HostMonitor" ending due to non existent /proc/<vm_pid>/stat
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mom
Version: 3.3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Martin Sivák
QA Contact: Lukas Svaty
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 21:18 UTC by Amador Pahim
Modified: 2019-04-28 09:13 UTC (History)
10 users (show)

Fixed In Version: vt12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:27:32 UTC
oVirt Team: SLA


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0186 normal SHIPPED_LIVE mom bug fix and enhancement update 2015-02-12 01:18:26 UTC
oVirt gerrit 32030 master MERGED Monitor should not crash when unexpected exception happens Never

Description Amador Pahim 2014-07-29 21:18:11 UTC
Description of problem:

For some currently unknown situation, collector failed to init() due to non-existent /proc/<vm_pid>/stat file:

2014-07-02 18:42:15,775 - mom.Collector - ERROR - Cannot open /proc/53049/stat: No such file or directory

This error is making "HostMonitor" end and mom stop:

2014-07-02 18:42:16,178 - mom - ERROR - Thread 'GuestManager' has exited
2014-07-02 18:42:16,204 - mom.HostMonitor - INFO - Host Monitor ending

The condition leading mom to try to access the stat of a non-existent pid is the subject of another ticket.

Version-Release number of selected component (if applicable):

vdsm-4.13.2-0.17.el6ev.x86_64

Actual results:

Host Monitor ending and mom stopped. No KSM/Balloon control until vdsmd service restart.

Expected results:

MOM thread to survive or restart after the error accessing the stat file.

Comment 2 Lukas Svaty 2014-12-22 11:35:33 UTC
Can you provide any verification steps on how to reproduce this?

Comment 3 Lukas Svaty 2015-01-02 13:05:05 UTC
verified manually by throwing previously unsupported  exception in the Monitor.collect method. This issue seems to be not reproducible in the latest versions vt13+ moving to VERIFIED

Comment 5 errata-xmlrpc 2015-02-11 20:27:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0186.html


Note You need to log in before you can comment on or make changes to this bug.