Bug 1124597 - Unable to register a host with 'subscription-manager': "Unable to verify server's identity:"
Summary: Unable to register a host with 'subscription-manager': "Unable to verify serv...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Registration
Version: Nightly
Hardware: x86_64
OS: Linux
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 21:26 UTC by Esa Varemo
Modified: 2017-02-23 21:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-01 15:22:18 UTC


Attachments (Terms of Use)
/etc/rhsm/rhsm.conf (1.62 KB, text/plain)
2014-07-29 21:26 UTC, Esa Varemo
no flags Details

Description Esa Varemo 2014-07-29 21:26:31 UTC
Created attachment 922354 [details]
/etc/rhsm/rhsm.conf

Description of problem:


Version-Release number of selected component (if applicable):
Trying to use 'subscription-manager' to register an existing host end up with "Unable to verify server's identity:"



How reproducible: Always



Steps to Reproduce:
1. Run `yum -y --nogpgcheck install http://foretello.ikioma/pub/katello-ca-consumer-foretello-1.0-1.noarch.rpm`
2. Run `subscription-manager register --org="ikioma" --activationkey="Centos6-x86_64"` or `subscription-manager register --org="ikioma" --environment="Library"`



Actual results:
Username prompt if --activationkey not specified.

The following error:
Unable to verify server's identity:



Expected results:
Host registers with foretello.


Additional info:


# foreman-debug


 HOSTNAME: foretello.ikioma
       OS: redhat
  RELEASE: CentOS release 6.5 (Final)
  FOREMAN: 1.6.0-develop
     RUBY: ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
   PUPPET: 3.6.2
  DENIALS: 366


A debug file has been created: /tmp/foreman-debug-GH8YC.tar.xz (232428 bytes)

You may want to upload the tarball to our public server via rsync. There is a
write only directory (readable only by Foreman core developers) for that. Note
the rsync transmission is UNENCRYPTED:

  rsync /tmp/foreman-debug-GH8YC.tar.xz rsync://theforeman.org/debug-incoming

Do you want to do this now? [y/N] y
Uploading...
The tarball has been uploaded, please contact us on mailing list or IRC.



# rpm -q foreman
foreman-1.6.0-0.develop.201407231606git49f11eb.el6.noarch

# rpm -q katello
katello-1.5.0-14.201407251440git86d0337.el6.noarch

# rpm -q candlepin
candlepin-0.9.21-1.el6.noarch

# rpm -qa |grep pulp
pulp-katello-0.3-3.el6.noarch
python-kombu-3.0.15-11.pulp.el6.noarch
createrepo-0.9.9-21.2.pulp.el6.noarch
pulp-nodes-common-2.4.0-0.24.beta.el6.noarch
python-isodate-0.5.0-1.pulp.el6.noarch
pulp-puppet-tools-2.4.0-0.24.beta.el6.noarch
python-pulp-common-2.4.0-0.24.beta.el6.noarch
python-rhsm-1.8.0-1.pulp.el6.x86_64
pulp-server-2.4.0-0.24.beta.el6.noarch
pulp-nodes-parent-2.4.0-0.24.beta.el6.noarch
m2crypto-0.21.1.pulp-8.el6.x86_64
python-pulp-puppet-common-2.4.0-0.24.beta.el6.noarch
pulp-rpm-plugins-2.4.0-0.24.beta.el6.noarch
pulp-selinux-2.4.0-0.24.beta.el6.noarch
python-pulp-rpm-common-2.4.0-0.24.beta.el6.noarch
mod_wsgi-3.4-1.pulp.el6.x86_64
pulp-puppet-plugins-2.4.0-0.24.beta.el6.noarch
python-pulp-bindings-2.4.0-0.24.beta.el6.noarch

Comment 1 RHEL Product and Program Management 2014-07-29 21:34:04 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Tom McKay 2014-07-30 18:31:47 UTC
Looking at logs I see errors in production.log related to communicating with pulp and /var/log/messages seems to indicate that mongodb is unreachable.

Please confirm that 'katello-service status' shows that mongodb is running and listening.

Any further information on your setup may help (proxy? enforcing?).

Comment 4 Esa Varemo 2014-09-01 15:22:18 UTC
The reason was that the database was on a partition that was not mounted. So no bug, just a user error.


Note You need to log in before you can comment on or make changes to this bug.