Bug 1124618 - [RFE] Allow Direct LUN based VMs on uninitialized Data Centers
Summary: [RFE] Allow Direct LUN based VMs on uninitialized Data Centers
Keywords:
Status: CLOSED DUPLICATE of bug 1082540
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Scott Herold
QA Contact: meital avital
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 23:09 UTC by Federico Simoncelli
Modified: 2015-11-19 13:36 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 13:36:06 UTC
oVirt Team: ---
sherold: Triaged+


Attachments (Terms of Use)

Description Federico Simoncelli 2014-07-29 23:09:55 UTC
Description of problem:
At the moment it is not possible to define and use direct luns when the data center is uninitialized (no storage domains). This means that in order to create VMs with disks on direct luns we are always forced to create at least one dummy master domain.

Allowing the direct luns consumption should be decoupled from the pool/spm as it would be also a step forward in removing the storage pool and the spm.

In addition this would also helpful for integrating with cinder and ceph (as their volumes could be treated as direct luns).

Comment 2 Scott Herold 2015-03-26 21:33:55 UTC
Federico, I'm doing some BZ cleanup aligned to 3.6.  Does this issue go away with the plans to remove the SPM role?

Comment 3 Allon Mureinik 2015-03-27 04:58:32 UTC
(In reply to Scott Herold from comment #2)
> Federico, I'm doing some BZ cleanup aligned to 3.6.  Does this issue go away
> with the plans to remove the SPM role?
It's a big step in the right direction, but not sufficient.
At the very least, the engine has a bunch of assumptions about DC statuses and how these related to SDs.

Comment 4 Scott Herold 2015-04-01 14:20:21 UTC
Removing from 3.6 due to capacity

Comment 5 Yaniv Kaul 2015-11-18 21:03:05 UTC
Dup of bug 1082540 ?

Comment 6 Allon Mureinik 2015-11-19 13:36:06 UTC
(In reply to Yaniv Kaul from comment #5)
> Dup of bug 1082540 ?
Yup.

*** This bug has been marked as a duplicate of bug 1082540 ***


Note You need to log in before you can comment on or make changes to this bug.