Bug 1124631 - Update to kernel 3.15.6-200 left grub without working grub.cfg file
Summary: Update to kernel 3.15.6-200 left grub without working grub.cfg file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 20
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 01:30 UTC by Rodd Clarkson
Modified: 2014-07-30 23:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 23:27:33 UTC


Attachments (Terms of Use)

Description Rodd Clarkson 2014-07-30 01:30:12 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Rodd Clarkson 2014-07-30 01:54:09 UTC
Sorry I hit enter in the subject field and it posted this.  Here's the rest. 

> Description of problem:

I ran yum update manually and my computer no longer boots to Fedora.  I get a grub prompt.

I've been searching around to find a solution, and it appears that my /boot/grub2/grub.cfg is all wrong.

I have the file but a listing of /boot/grub2 shows:


# ls -l
ls: cannot access grub.cfg: Input/output error
total 21
-rw-rw-r--. 1 root root   84 Oct 27  2013 device.map
drwxrwxr-x. 2 root root 1024 Oct 27  2013 fonts
drwxr-xr-x. 5 root root 1024 Jul 29 21:10 grub2
-?????????? ? ?    ?       ?            ? grub.cfg
-rw-rw-r--. 1 root root 1024 Jul 20 00:45 grubenv
drwxrwxr-x. 2 root root 8192 Oct 27  2013 i386-pc
drwxrwxr-x. 2 root root 1024 Oct 27  2013 locale
drwxr-xr-x. 3 root root 1024 May  9  2012 themes

NOTE: the second line and the ??? along with grub.cfg



> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:

Only on my system so far, but not sure why it hit me.  The update was completed (as far as I'm aware) before I restarted my system (and I'm pretty sure that yum blocks restarts if it's runnning) and I used the poweroff option in gnome.

> More Information:

I've tried copying a grub.cfg file from another system to replace this one by I can't even do this.  I get the same Input/Output error.

# cp grub.cfg sda1/grub2/
cp: cannot stat ‘sda1/grub2/grub.cfg’: Input/output error


What else do you need?

Comment 2 Rodd Clarkson 2014-07-30 01:57:22 UTC
When I run

# cp grub.cfg sda1/grub2/
cp: cannot stat ‘sda1/grub2/grub.cfg’: Input/output error

dmesg reports:

[ 3285.130144] EXT4-fs error (device sda1): ext4_lookup:1437: inode #65027: comm cp: deleted inode referenced: 65043

Comment 3 Rodd Clarkson 2014-07-30 01:59:40 UTC
Found a page that suggested using unlink

This is the output:

# unlink grub.cfg 
unlink: cannot unlink ‘grub.cfg’: Input/output error



Oh, I should mention that the disk is a SSD that seems to be working fine.  A look at the SMART information shows no errors.

Comment 4 Rodd Clarkson 2014-07-30 02:03:49 UTC
I umounted to drive and ran fsck on the device and it fixed the following:

# fsck /dev/sda1
fsck from util-linux 2.24
e2fsck 1.42.8 (20-Jun-2013)
/dev/sda1 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Extended attribute block 266256 has reference count 575, should be 574.  Fix<y>? yes
Pass 2: Checking directory structure
Entry 'grub.cfg' in /grub2 (65027) has deleted/unused inode 65043.  Clear<y>? yes
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Block bitmap differences:  -4372 -8452 -(9612--9750) -(155649--171445) +(182273--198046) -270338 -(270851--270858) -270860 -271892
Fix<y>? yes
Free blocks count wrong for group #0 (3811, counted=3814).
Fix<y>? yes
Free blocks count wrong for group #1 (1149, counted=1288).
Fix<y>? yes
Free blocks count wrong for group #3 (7335, counted=2478).
Fix<y>? yes
Free blocks count wrong for group #4 (3643, counted=281).
Fix<y>? yes
Free blocks count wrong for group #21 (1308, counted=8192).
Fix<y>? yes
Free blocks count wrong for group #22 (755, counted=2048).
Fix<y>? yes
Free blocks count wrong for group #33 (2456, counted=2467).
Fix<y>? yes
Free blocks count wrong (333647, counted=333758).
Fix<y>? yes
Inode bitmap differences:  -65043
Fix<y>? yes
Free inodes count wrong for group #32 (1393, counted=1394).
Fix<y>? yes
Free inodes count wrong (127346, counted=127347).
Fix<y>? yes

/dev/sda1: ***** FILE SYSTEM WAS MODIFIED *****
/dev/sda1: 669/128016 files (1.2% non-contiguous), 178242/512000 blocks



Not sure what went wrong and this definitely shouldn't happen when updating a system.

Comment 5 Brian Lane 2014-07-30 23:27:33 UTC
filesystem corruption isn't something grub2 can be expected to deal with.


Note You need to log in before you can comment on or make changes to this bug.