Bug 1124689 - Deployment content not removed from disconnected host controllers
Summary: Deployment content not removed from disconnected host controllers
Keywords:
Status: CLOSED DUPLICATE of bug 1018026
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: EAP 6.4.0
Assignee: Emmanuel Hugonnet (ehsavoie)
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 05:50 UTC by James Livingston
Modified: 2018-12-06 17:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-01 00:21:00 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-122 Major Resolved Clean unreferenced items from the content repository 2017-04-27 14:30:01 UTC

Description James Livingston 2014-07-30 05:50:52 UTC
If a deployment is undeployed while one of the slave HCs is not connected, then the deployment will not be removed from the HC's content repository.

Some notes on this are on https://issues.jboss.org/browse/WFLY-122, but I'm not certain whether that issue is identical to this one.

To reproduce (exists on EAP 6.3 ER10 and WF 8.1)

1) Start a DC and slave HC
2) Deploy an application to a server group on the slave HC
  - content will be copied to the slave
3) Undeploy the application
 -  content will be removed from the slave
4) Deploy the app again
 - content copied to the slave
5) Shut down the slave
6) Undeploy the application
7) Start the slave back up
 - content is never removed

Comment 3 James Livingston 2014-08-01 00:21:00 UTC
Thanks, I didn't see that one when searching. I'll mark this as a duplicate.

*** This bug has been marked as a duplicate of bug 1018026 ***

Comment 4 JBoss JIRA Server 2014-09-23 14:09:12 UTC
Emmanuel Hugonnet <ehugonne@redhat.com> updated the status of jira WFLY-122 to Coding In Progress


Note You need to log in before you can comment on or make changes to this bug.