Bug 112469 - Autohide auto_hide_size bad default value
Autohide auto_hide_size bad default value
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
1
i686 Linux
low Severity low
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-20 04:47 EST by Bart Martens
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-20 07:52:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-panel-2.4.0-autohidesize.patch (557 bytes, patch)
2004-02-05 21:07 EST, Bart Martens
no flags Details | Diff

  None (edit)
Description Bart Martens 2003-12-20 04:47:59 EST
Description of problem:
Bad default value of auto_hide_size. And, auto_hide_size is missing on
the "panel properties" dialog box.

Version-Release number of selected component (if applicable):
gnome-panel-2.4.0-3

Steps to Reproduce:
Use autohide.

Actual Results: Too much of the panel still visible. And, no way to
fix this on "panel properties".

Expected Results: Default value of auto_hide_size should be 1 (or 0 if
possible). And, the "panel properties" should allow to modify
auto_hide_size.

Workaround: use gconf-editor, select "/ apps panel profiles default
toplevels bottom_panel", and modify auto_hide_size to 1.
Comment 1 Bart Martens 2004-02-05 18:36:27 EST
Also known at:
http://bugzilla.gnome.org/show_bug.cgi?id=127973
Comment 2 Bart Martens 2004-02-05 21:07:14 EST
Created attachment 97509 [details]
gnome-panel-2.4.0-autohidesize.patch

This patch sets the default auto_hide_size to 1.
Comment 3 Leonard den Ottolander 2004-02-12 13:10:40 EST
Not sure if this is something to be "fixed". 6 pixels is allright for
me, so this is probably a matter of opinion. Are you sure the panel
will even reappear if you set the auto_hide_size to 0?

Would be nice if this would be configurable, but just setting
auto_hide_size to 1 doesn't seem to be the way to go.
Comment 4 Leonard den Ottolander 2004-02-18 15:36:56 EST
What is this patch supposed to do? I applied it but don't see any
change. Should there be a visible change or only a functional one?
Comment 5 Bart Martens 2004-02-19 00:33:04 EST
Thank you for testing. It doesn't change the current settings when
upgrading. It only sets the default initial value to 1 instead of 6.
There is more test feedback on the bug report at gnome.
Comment 6 Mark McLoughlin 2004-02-20 07:52:23 EST
This being tracked upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=127973

closing out as UPSTREAM
Comment 7 Leonard den Ottolander 2004-02-20 09:49:31 EST
I'm not sure closing this bug as UPSTREAM at the current stage is a
good solution. We first have to establish if this needs to be fixed in
Fedora Core 1. - Personally I think not as this patch doesn't seem to
have any positive impact when doing an *update*, but this is just one
opinion. - If not it might just as well be closed WONTFIX.

Please reopen and have a discussion (on fedora-devel) first.

(If this were a single issue I wouldn't mind it being closed right
now, but since there are other issues that need to be addressed this
issue could be addressed at the same time just as well.)

Note You need to log in before you can comment on or make changes to this bug.