Bug 1124711 - nfs-ganesha.enable off fails to stop nfs-ganesha due to a dbus error in upstream nfs-ganesha.
Summary: nfs-ganesha.enable off fails to stop nfs-ganesha due to a dbus error in upstr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Meghana
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 07:18 UTC by Meghana
Modified: 2015-09-01 02:54 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Meghana 2014-07-30 07:18:16 UTC
Description of problem:
gluster vol set nfs-ganesha.enable off must unexport a volume that
was already exported via nfs-ganesha. This is doesn't happen when ganesha sources above v2.1 are used.

Version-Release number of selected component (if applicable):
nfs-ganesha v2.1 and above

How reproducible:
Always

Steps to Reproduce:
1. Export a volume testvol via nfs-ganesha 
2. Execute, gluster vol set testvol nfs-ganesha.enable off
3.

Actual results:
showmount -e localhost,
/testvol (everyone)

Expected results:
testvol shouldn't be an export anymore


Additional info:
This happens because of a change in upstream nfs-ganesha.

Comment 1 Anand Avati 2014-07-30 08:25:20 UTC
REVIEW: http://review.gluster.org/8390 (gluster vol set nfs-ganesha.enable off fails to unexport volume.) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 2 Anand Avati 2014-08-05 10:33:47 UTC
COMMIT: http://review.gluster.org/8390 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 866a9b96212989ea2cad399a56bb4b71623c6b0c
Author: Meghana Madhusudhan <mmadhusu@redhat.com>
Date:   Tue Jul 29 18:51:21 2014 +0530

    gluster vol set nfs-ganesha.enable off fails to unexport volume.
    
     Due to a parameter type change in upstream nfs-ganesha
    ( v2.1 and above ), gluster vol set <volname> nfs-ganesha.enable
     off doesn't unexport the volume in question if it was already
    exported.
    A minor change in the hook script would result in the
    expected behaviour.
    
    Change-Id: I46f76f3cde6b6ebd7a94d5ee16f05a3648a2840f
    BUG: 1124711
    Signed-off-by: Meghana Madhusudhan <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/8390
    Reviewed-by: soumya k <skoduri@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:26:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:37:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:42:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.