Bug 1124728 - SMB: CIFS mount fails with the latest glusterfs rpm's
Summary: SMB: CIFS mount fails with the latest glusterfs rpm's
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: gluster-smb
Version: 3.5.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Poornima G
QA Contact:
URL:
Whiteboard:
Depends On: 1084964
Blocks: glusterfs-3.5.2
TreeView+ depends on / blocked
 
Reported: 2014-07-30 07:53 UTC by Niels de Vos
Modified: 2014-07-31 11:44 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.5.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1084964
Environment:
Last Closed: 2014-07-31 11:44:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2014-07-30 07:53:44 UTC
+++ This bug was initially created as a clone of Bug #1084964 +++

+++ This bug was initially created as a clone of Bug #1084958 +++

Description of problem:
=========================================
Tried the following workaround to install glusterfs-server:
mkdir -p /var/lib/glusterd/hooks/1/{start,stop,add-brick,set}/{pre,post}
running that before yum install glusterfs-server 
Once the gluster packages are installed, mount of gluster volume via SMB is failing.

 
Version-Release number of selected component (if applicable):
glusterfs-server-3.5qa2-0.304.git0c1d78f.el6rhs.x86_64

How reproducible:
Tried cifs mount several times.

Steps to Reproduce:
1.Install the latest glusterfs rpm's
2.Mount the volume via cifs 


Actual results:
The mount of gluster volume via SMB fails.

Expected results:
The SMB mount should happen successfully.

Additional info:

--- Additional comment from Anand Avati on 2014-04-07 14:17:10 CEST ---

REVIEW: http://review.gluster.org/7409 (gfapi: In glfs_set_volfile_server() remove the port number check.) posted (#1) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Anand Avati on 2014-04-08 10:35:39 CEST ---

COMMIT: http://review.gluster.org/7409 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 6567d141c1b0112acb35e711371ae5a879fc645a
Author: Poornima G <pgurusid@redhat.com>
Date:   Mon Apr 7 17:38:32 2014 +0530

    gfapi: In glfs_set_volfile_server() remove the port number check.
    
    The documentation for glfs_set_volfile_server() api says that the
    port zero is a valid value. Specifying 0 uses the default port
    number GF_DEFAULT_BASE_PORT. Hence removing the check for port being
    zero.
    
    Change-Id: I942a7fe54a418231a438ab67756537df8f28d2de
    BUG: 1084964
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/7409
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

--- Additional comment from Anand Avati on 2014-07-25 09:50:53 CEST ---

REVIEW: http://review.gluster.org/8374 (gfapi: In glfs_set_volfile_server() remove the port number check.) posted (#1) for review on release-3.5 by Poornima G (pgurusid@redhat.com)

Comment 1 Anand Avati 2014-07-30 08:02:06 UTC
REVIEW: http://review.gluster.org/8374 (gfapi: In glfs_set_volfile_server() remove the port number check.) posted (#2) for review on release-3.5 by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2014-07-31 07:50:59 UTC
COMMIT: http://review.gluster.org/8374 committed in release-3.5 by Niels de Vos (ndevos@redhat.com) 
------
commit a0cb3b0665bfbe321b8a21d609cfc2defb572084
Author: Poornima G <pgurusid@redhat.com>
Date:   Mon Apr 7 17:38:32 2014 +0530

    gfapi: In glfs_set_volfile_server() remove the port number check.
    
    The documentation for glfs_set_volfile_server() api says that the
    port zero is a valid value. Specifying 0 uses the default port
    number GF_DEFAULT_BASE_PORT. Hence removing the check for port being
    zero.
    
    Master branch commit 6567d141c1b0112acb35e711371ae5a879fc645a:
    > Change-Id: I942a7fe54a418231a438ab67756537df8f28d2de
    > BUG: 1084964
    > Signed-off-by: Poornima G <pgurusid@redhat.com>
    > Reviewed-on: http://review.gluster.org/7409
    > Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    > Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    
    Change-Id: I942a7fe54a418231a438ab67756537df8f28d2de
    BUG: 1124728
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/8374
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 3 Niels de Vos 2014-07-31 11:44:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.2, please reopen this bug report.

glusterfs-3.5.2 has been announced on the Gluster Users mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-July/041217.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.