Bug 1124732 - Can't display guests' "state" in the virt-who log
Summary: Can't display guests' "state" in the virt-who log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who
Version: 5.11
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Radek Novacek
QA Contact: gaoshang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 08:01 UTC by Liushihui
Modified: 2016-12-01 00:33 UTC (History)
3 users (show)

Fixed In Version: virt-who-0.9-6.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-16 00:29:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1206 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2014-09-16 04:16:42 UTC

Description Liushihui 2014-07-30 08:01:21 UTC
Description of problem:
After system has been registered to SAM server , check the virt-who log, the parameter of "state " isn't exist in the "Sending list of uuids:".

Version-Release number of selected component (if applicable):
subscription-manager-1.11.3-10.el5
python-rhsm-1.11.3-5.el5
virt-who-0.9-5.el5
katello-headpin-1.4.3.26-1.el6sam_splice.noarch
candlepin-0.9.6.4-1.el6sam.noarch

How reproducible:
Always

Steps to Reproduce:
1.Register system to SAM server
# subscription-manager register --username=admin --password=admin
2. Configure virt-who run at libvirtd mode
# vim /etc/sysconfig/virt-who
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=5
3. Restart virt-who service, virt-who send host/guest associate to SAM server
# service virt-who restart
4. Check the virt-who's log

Actual results:
Check the "Sending list of uuids:",The pamameter of "state" isn't exist in every guest. Please see detail as the following:
[NOTE]: It hasn't this problem on RHEL7 and RHEL6.6
2014-07-30 02:42:36,250 [DEBUG]  @subscriptionmanager.py:101 - Sending list of uuids: [
{'guestId': '1c305052-5da7-2570-ee7d-f12377230e3d', 'attributes': {'active': 0, 'virtWhoType': 'libvirt', 'hypervisorType': 'QEMU'}},
{'guestId': '2127d3fa-939f-45a3-250f-21d37d6e259c', 'attributes': {'active': 0, 'virtWhoType': 'libvirt', 'hypervisorType': 'QEMU'}}, 
{'guestId': '8cbcfd84-aaea-b879-3d48-f12d5143cb46', 'attributes': {'active': 0, 'virtWhoType': 'libvirt', 'hypervisorType': 'QEMU'}}, 
{'guestId': '9e1094f4-f630-b14d-913a-706a2261d2bd', 'attributes': {'active': 0, 'virtWhoType': 'libvirt', 'hypervisorType': 'QEMU'}}, 
{'guestId': 'f653f9dd-2795-25c1-77a9-3f823d48f153', 'attributes': {'active': 0, 'virtWhoType': 'libvirt', 'hypervisorType': 'QEMU'}}]

Expected results:
It should display guests' "state" in the uuidlist, the same as the following:
2014-07-30 15:23:06,595 [INFO]  @subscriptionmanager.py:109 - Sending list of uuids: [{
'guestId': '0804e244-3b17-322e-e115-e5cc33a1e502', 'attributes': {'active': 0, 'virtWhoType': 'libvirt', 'hypervisorType': 'QEMU'}, 'state': 5}, 
{'guestId': '7ba87819-858e-b6cc-2f77-3b6e7e44be2c', 'attributes': {'active': 0, 'virtWhoType': 'libvirt', 'hypervisorType': 'QEMU'}, 'state': 5}, 
{'guestId': '70144381-3aaf-9515-3a51-6e2114006451', 'attributes': {'active': 1, 'virtWhoType': 'libvirt', 'hypervisorType': 'QEMU'}, 'state': 1}]

Additional info:

Comment 1 Radek Novacek 2014-07-30 08:44:11 UTC
libvirt on RHEL-5 doesn't have the state() method that is used on RHEL-6 and RHEL-7. However this information can be also obtained from info() method.

Comment 3 Radek Novacek 2014-08-04 12:27:49 UTC
Fixed in virt-who-0.9-6.el5.

Comment 5 Liushihui 2014-08-08 05:22:42 UTC
Verified on virt-who-0.9-6.el5

Comment 7 errata-xmlrpc 2014-09-16 00:29:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1206.html


Note You need to log in before you can comment on or make changes to this bug.