Bug 1124780 - api: silently ignore `cartridges` parameter on app create
Summary: api: silently ignore `cartridges` parameter on app create
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Master
Version: 2.x
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Sally
QA Contact: Wei Sun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 09:55 UTC by Aleksandar Kostadinov
Modified: 2017-05-31 18:22 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-31 18:22:11 UTC


Attachments (Terms of Use)

Description Aleksandar Kostadinov 2014-07-30 09:55:08 UTC
Consider a request  like:
> https://<server>/broker/rest/domain/vr0c0j/applications {
>   "name":"kzhklrgu",
>   "cartridges":"php-5.4",
>   "gear_size":"small",
>   "cartridge":[
>     {"url":"https://raw.githubusercontent.com/openshift-qe/download-cart-mysql/master/metadata/manifest.yml"}
>   ]
> }

Description of problem:
A php-5.4 app is created but the cartridges parameter is silently ignored thus the additional add-on cart is not added to the app. I think `cartridges` and `cartridge` parameters should be both processed or an error should be returned to the user.

Version-Release number:
current int environment

How reproducible:
always

Comment 2 Sally 2016-01-26 22:44:25 UTC
this works for me (notice cartridge=, not cartridges= )

curl -k -X POST https://<server>/broker/rest/domain/mydomain/applications --user username --data-urlencode name=myapp2 --data-urlencode cartridge=ruby-2.0 --data-urlencode scale=true --data-urlencode gear_size=small

(not able to reproduce)

QA: there have been no other complaints since this initial report.

Comment 3 weiwei jiang 2016-02-03 09:59:37 UTC
Checked with devenv_5760, can not reproduce this issue.

Comment 5 Eric Paris 2017-05-31 18:22:11 UTC
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.


Note You need to log in before you can comment on or make changes to this bug.