Bug 1124785 - SMB: On cifs mount running cp -al command on a directory with files gives "preserving permissions Input/output error"
Summary: SMB: On cifs mount running cp -al command on a directory with files gives "pr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.0.4
Assignee: Poornima G
QA Contact: surabhi
URL:
Whiteboard: core
Depends On:
Blocks: 1154035 1182947
TreeView+ depends on / blocked
 
Reported: 2014-07-30 10:03 UTC by surabhi
Modified: 2015-05-13 17:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1154035 (view as bug list)
Environment:
Last Closed: 2015-03-26 06:22:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0680 normal SHIPPED_LIVE Red Hat Storage 3.0 gluster-samba enhancement and bug fix update #1 2015-03-26 10:22:14 UTC

Description surabhi 2014-07-30 10:03:39 UTC
Description of problem:
****************************************
On cifs mount after creating a directory/files,executing cp -al(preserves/archive) on directory gives error w.r.t. preserving permissions.

 mkdir testdir
 cd testdir
 ls
 touch f{1..10}
 ls
 f1  f10  f2  f3  f4  f5  f6  f7  f8  f9
 cd ..
 cp -al testdir testdirnew
 cp: preserving permissions for `testdirnew': Input/output error

The log shows following error:
[2014/07/30 04:00:35.293302,  0] modules/vfs_glusterfs.c:579(vfs_gluster_stat)
  glfs_stat(./..) failed: Input/output error
[2014/07/30 04:01:55.379883,  0] modules/vfs_glusterfs.c:579(vfs_gluster_stat)
  glfs_stat(./..) failed: Input/output error


Version-Release number of selected component (if applicable):
glusterfs-geo-replication-3.6.0.25-1.el6rhs.x86_64
glusterfs-fuse-3.6.0.25-1.el6rhs.x86_64
glusterfs-rdma-3.6.0.25-1.el6rhs.x86_64
glusterfs-cli-3.6.0.25-1.el6rhs.x86_64
glusterfs-libs-3.6.0.25-1.el6rhs.x86_64
glusterfs-3.6.0.25-1.el6rhs.x86_64
glusterfs-devel-3.6.0.25-1.el6rhs.x86_64
glusterfs-server-3.6.0.25-1.el6rhs.x86_64
glusterfs-debuginfo-3.6.0.25-1.el6rhs.x86_64
samba-glusterfs-3.6.9-168.4.el6rhs.x86_64
glusterfs-api-3.6.0.25-1.el6rhs.x86_64
glusterfs-api-devel-3.6.0.25-1.el6rhs.x86_64


How reproducible:
Always

Steps to Reproduce:
1.create a volume
2.mount it via cifs
3.Create a directory on the mount point and create files inside the directory 
4. Do cp -al (which is to do archive permissions)

Actual results:
It fails with following error:
# cp -al testdir testdirnew
cp: preserving permissions for `testdirnew': Input/output error

Expected results:
Copying premissions should not fail


Additional info:

Comment 5 Poornima G 2015-02-16 12:21:50 UTC
The fix for it goes as a part of Samba package, there is no patch for this in glusterfs, will add the Samba package version once the build is final.

Comment 7 surabhi 2015-03-01 14:12:06 UTC
The bug is been verified with following steps:
 mkdir testdir
 cd testdir
 ls
 touch f{1..10}
 ls
 f1  f10  f2  f3  f4  f5  f6  f7  f8  f9
 cd ..
 cp -al testdir testdirnew

Permissions for directory gets copied successfully.
verified the bug on samba build: 
samba-winbind-modules-4.1.16-5.el6rhs.x86_64
samba-winbind-4.1.16-5.el6rhs.x86_64
samba-winbind-clients-4.1.16-5.el6rhs.x86_64
samba-vfs-glusterfs-4.1.16-5.el6rhs.x86_64
samba-debuginfo-4.1.16-5.el6rhs.x86_64
samba-common-4.1.16-5.el6rhs.x86_64
samba-winbind-krb5-locator-4.1.16-5.el6rhs.x86_64
samba-4.1.16-5.el6rhs.x86_64
samba-libs-4.1.16-5.el6rhs.x86_64
samba-client-4.1.16-5.el6rhs.x86_64

Comment 9 errata-xmlrpc 2015-03-26 06:22:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0680.html


Note You need to log in before you can comment on or make changes to this bug.