Bug 1124791 - testsuite test main.openssl_1 is broken
Summary: testsuite test main.openssl_1 is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: mariadb
Version: rh-mariadb100
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 1.2
Assignee: Honza Horak
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 10:15 UTC by Branislav Blaškovič
Modified: 2015-06-04 08:39 UTC (History)
3 users (show)

Fixed In Version: rh-mariadb100-mariadb-10.0.17-9.el6, rh-mariadb100-mariadb-10.0.17-9.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-04 08:39:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1062 normal SHIPPED_LIVE new packages: rh-mariadb100 2015-06-04 12:38:38 UTC

Description Branislav Blaškovič 2014-07-30 10:15:32 UTC
Description of problem:
    We have strange situation here. Testsuite of mariadb is failing on test:
    main.openssl_1

Version-Release number of selected component (if applicable):
    mariadb55-mariadb-5.5.37-9.el6.x86_64
    mariadb55-mariadb-test-5.5.37-9.el6.x86_64

Steps to Reproduce:
    1. Install package mariadb55-mariadb-test
    2. cd /opt/rh/mariadb55/root/usr/share/mysql-test
    3. ./mysql-test-run main.openssl_1

Actual results:
    # ./mysql-test-run main.openssl_1
    Logging: ./mysql-test-run  main.openssl_1
    vardir: /opt/rh/mariadb55/root/usr/share/mysql-test/var
    Checking leftover processes...
    Removing old var directory...
    Creating var directory '/opt/rh/mariadb55/root/usr/share/mysql-test/var'...
    Checking supported features...
    MariaDB Version 5.5.37-MariaDB
    Installing system database...
     - SSL connections supported
    Collecting tests...

    ==============================================================================

    TEST                                      RESULT   TIME (ms) or COMMENT
    --------------------------------------------------------------------------

    worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 16000..16019
    worker[1] mysql-test-run: WARNING: running this script as _root_ will cause some tests to be skipped
    main.openssl_1                           [ fail ]
            Test ended at 2014-07-30 06:03:08

    CURRENT_TEST: main.openssl_1
    ERROR 2026 (HY000): SSL connection error: error:00000001:lib(0):func(0):reason(1)
    mysqltest: At line 221: exec of '/opt/rh/mariadb55/root/usr/bin/mysql --defaults-file=/opt/rh/mariadb55/root/usr/share/mysql-test/var/my.cnf --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=EDH-RSA-DES-CBC-SHA' failed, error: 256, status: 1, errno: 0
    Output from before failure:
    Variable_name   Value
    Ssl_cipher  EDH-RSA-DES-CBC3-SHA



    The result from queries just before the failure was:
    < snip >
    INSERT INTO `t1` VALUES (1),(2);
    /*!40000 ALTER TABLE `t1` ENABLE KEYS */;
    UNLOCK TABLES;
    /*!40103 SET TIME_ZONE=@OLD_TIME_ZONE */;

    /*!40101 SET SQL_MODE=@OLD_SQL_MODE */;
    /*!40014 SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS */;
    /*!40014 SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS */;
    /*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
    /*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
    /*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;
    /*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;

    SSL error: Unable to get private key from 'MYSQL_TEST_DIR/std_data/client-cert.pem'
    mysqldump: Got error: 2026: "SSL connection error: Unable to get private key" when trying to connect
    DROP TABLE t1;
    Variable_name   Value
    Ssl_cipher  DHE-RSA-AES256-SHA
    Variable_name   Value
    Ssl_cipher  EDH-RSA-DES-CBC3-SHA

    More results from queries before failure can be found in /opt/rh/mariadb55/root/usr/share/mysql-test/var/log/openssl_1.log

     - saving '/opt/rh/mariadb55/root/usr/share/mysql-test/var/log/main.openssl_1/' to '/opt/rh/mariadb55/root/usr/share/mysql-test/var/log/main.openssl_1/'
    --------------------------------------------------------------------------
    The servers were restarted 0 times
    Spent 0.000 of 2 seconds executing testcases

    Failure: Failed 1/1 tests, 0.00% were successful.

    Failing test(s): main.openssl_1

    The log files in var/log may give you some hint of what went wrong.

    If you want to report this error, please read first the documentation
    at http://dev.mysql.com/doc/mysql/en/mysql-test-suite.html

    mysql-test-run: *** ERROR: there were failing test cases



Expected results:
    Test passes


Additional info:
    Well, its weird because during testing of RHSCL 1.1 this test passes:
        https://tcms.engineering.redhat.com/run/137000/#caserun_5118469
    Log:
        http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2014/05/6541/654109/1357175/21275036/TESTOUT.logo
    Version:
        mariadb55-mariadb-5.5.37-9.el6.x86_64
        mariadb55-mariadb-test-5.5.37-9.el6.x86_64

    And now, the same run but it was run just few days ago:
        https://tcms.engineering.redhat.com/run/162933/#caserun_6465896
    Log:
        http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2014/07/7054/705409/1468954/23109514/TESTOUT.log
    Version:
        mariadb55-mariadb-5.5.37-9.el6.x86_64
        mariadb55-mariadb-test-5.5.37-9.el6.x86_64


So, the bug would be in openssl I think. Please investigate and reassign the bug if necessary.

Comment 2 Honza Horak 2014-08-04 10:39:44 UTC
This change is only in the test suite, should not influence usual functionality. It is most probably caused by a change in openssl's default cypher set and the test just expects different output. Thus, moving to RHSCL-2.0.

Comment 3 Honza Horak 2015-03-17 20:43:37 UTC
Should be fixed with latest upstream source.

Comment 11 Branislav Blaškovič 2015-05-05 12:01:19 UTC
:: [ 07:59:10 ] :: Package versions:
:: [ 07:59:10 ] ::   rh-mariadb100-mariadb-10.0.17-9.el7.x86_64
:: [ 07:59:11 ] ::   rh-mariadb100-mariadb-server-10.0.17-9.el7.x86_64
:: [ 07:59:11 ] ::   rh-mariadb100-mariadb-test-10.0.17-9.el7.x86_64
...
:: [  BEGIN   ] :: Running the test suite :: actually running 'su mysql -c './mysql-test-run --skip-test-list=rh-skipped-tests.list --vardir=/var/opt/rh/rh-mariadb100/lib/mysql/testxCy --force main.openssl_1 2>&1 | tee /tmp/tmp.yhTJIfHetu''
Logging: ./mysql-test-run  --skip-test-list=rh-skipped-tests.list --vardir=/var/opt/rh/rh-mariadb100/lib/mysql/testxCy --force main.openssl_1
vardir: /var/opt/rh/rh-mariadb100/lib/mysql/testxCy
Removing old var directory...
Creating var directory '/var/opt/rh/rh-mariadb100/lib/mysql/testxCy'...
Checking supported features...
MariaDB Version 10.0.17-MariaDB
 - SSL connections supported
Collecting tests...
Installing system database...

==============================================================================

TEST                                      RESULT   TIME (ms) or COMMENT
--------------------------------------------------------------------------

worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 16000..16019
main.openssl_1                           [ pass ]   1071
--------------------------------------------------------------------------
The servers were restarted 0 times
Spent 1.071 of 5 seconds executing testcases

Completed: All 1 tests were successful.

:: [   PASS   ] :: Running the test suite (Expected 0, got 0)



:: [ 07:59:50 ] :: Package versions:
:: [ 07:59:50 ] ::   rh-mariadb100-mariadb-10.0.17-9.el6.x86_64
:: [ 07:59:51 ] ::   rh-mariadb100-mariadb-server-10.0.17-9.el6.x86_64
:: [ 07:59:51 ] ::   rh-mariadb100-mariadb-test-10.0.17-9.el6.x86_64
...
:: [  BEGIN   ] :: Running the test suite :: actually running 'su mysql -c './mysql-test-run --skip-test-list=rh-skipped-tests.list --vardir=/var/opt/rh/rh-mariadb100/lib/mysql/testZUf --force main.openssl_1 2>&1 | tee /tmp/tmp.ftQS4rYa27''
Logging: ./mysql-test-run  --skip-test-list=rh-skipped-tests.list --vardir=/var/opt/rh/rh-mariadb100/lib/mysql/testZUf --force main.openssl_1
vardir: /var/opt/rh/rh-mariadb100/lib/mysql/testZUf
Removing old var directory...
Creating var directory '/var/opt/rh/rh-mariadb100/lib/mysql/testZUf'...
Checking supported features...
MariaDB Version 10.0.17-MariaDB
 - SSL connections supported
Collecting tests...
Installing system database...

==============================================================================

TEST                                      RESULT   TIME (ms) or COMMENT
--------------------------------------------------------------------------

worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 16000..16019
main.openssl_1                           [ pass ]    649
--------------------------------------------------------------------------
The servers were restarted 0 times
Spent 0.649 of 4 seconds executing testcases

Completed: All 1 tests were successful.

:: [   PASS   ] :: Running the test suite (Expected 0, got 0)


Switching to verified.

Comment 12 Branislav Blaškovič 2015-05-19 13:54:20 UTC
Removing FailedQA from latest respin.

Comment 14 errata-xmlrpc 2015-06-04 08:39:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1062.html


Note You need to log in before you can comment on or make changes to this bug.