Bug 112480 - hang after the message 'Freeing unused kernel memory: 136k freed'
hang after the message 'Freeing unused kernel memory: 136k freed'
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Depends On:
  Show dependency treegraph
Reported: 2003-12-20 12:56 EST by Daniel Kennedy
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-29 15:52:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output of the loader messages before GRUB hangs (262 bytes, text/plain)
2003-12-20 12:57 EST, Daniel Kennedy
no flags Details

  None (edit)
Description Daniel Kennedy 2003-12-20 12:56:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; MyIE2; 

Description of problem:
On bootstrapping, the system boots from GRUB perfectly well until it 
comes to the section shown in the attached file. It sits there after 
the message 'Freeing unused kernel memory: 136k freed' and requires a 
reboot to.. produce the message again. I have also tried booting with 
linux nofb, to no avail. Any help you can provide would be greatly 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Turn on machine
2. Wait

Actual Results:  Hangs after mentioned message

Expected Results:  Loads Fedora Core 1

Additional info:
Comment 1 Daniel Kennedy 2003-12-20 12:57:36 EST
Created attachment 96655 [details]
Output of the loader messages before GRUB hangs

Attached are the messages I get before GRUB hangs.
Comment 2 Daniel Kennedy 2003-12-27 18:40:33 EST
As a sidnote, this also occurs on Red Hat 9 (Shrike) whilst using the 
LILO boot mngr. When I can get it into a rescue shell (its not doing 
it right now, for some unknown reason) I will attach 
my /etc/lilo.conf for you.
Comment 3 Arjan van de Ven 2003-12-28 04:50:42 EST
apm=off is most likely workaround; if that fixes it your bios can't
handle apm idle calls even though it advertises it can
Comment 4 Jim Hanley 2004-02-18 08:16:12 EST
I am seeing this on my machine too, I have three different kernels 
(from progressive kernel updates) in my grub config, and all three 
hang at this same spot.
Comment 5 Scott Deacon 2004-04-19 20:47:18 EDT
Fails on mine as well (last 2 arjanv kernels). apm=off has no effect.
Comment 6 Alexander Sirotkin 2004-04-22 11:46:16 EDT
Can confirm this on my dell C600 (PIII) laptop. apm=off did not help.
Comment 7 Alexander Sirotkin 2004-04-22 11:47:27 EDT
One more comment - it only happened when I upgraded to the 2.6 kernel
(Fedora Core 2)
Comment 8 Dave Jones 2004-04-22 12:58:55 EDT
Are you using FC1 userspace ? or old FC2 glibc ?
Does booting with vdso=0 fix it?
Comment 9 Scott Deacon 2004-04-22 16:44:04 EDT
My machine is arjanv kernels on FC1. vsdo=0 deos fix it.
Comment 10 Paul Chauvet 2004-05-04 10:40:50 EDT
I have gotten this error on a Dell PowerEdge 2650 running Redhat EL
3.0.  It boots fine with kernel-smp-2.6.4-1.302 but not with
kernel-smp- (or a couple others I've tried from
people.redhat.com/arjanv inbetween 2.6.4-1.302 and

Same freeze at 'Freeing unused kernel memory'
Comment 11 Paul Chauvet 2004-05-04 16:09:31 EDT
Well, stupid me posted this in the Fedora section, rather then the EL
section, but either way, the vdso=0 does fix it.  Sorry for the wrong
post location
Comment 12 Dinil Divakaran 2004-06-25 23:15:18 EDT
My system also hangs after the messaged 'Freeing unused kernel memory'.
I am using 2.6.7-1.448 kernel. where should i add vsdo=0? What does it
do ?
Comment 13 David Lawrence 2004-09-29 15:52:18 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.