Bug 1124804 - Switch to SQLAlchemy "back_populates" directive
Summary: Switch to SQLAlchemy "back_populates" directive
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general
Version: 0.17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 20.0
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 11:20 UTC by Nick Coghlan
Modified: 2018-02-06 00:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-20 02:22:39 UTC


Attachments (Terms of Use)

Description Nick Coghlan 2014-07-30 11:20:28 UTC
Currently, the Beaker model files use the SQL Alchemy "backrefs" directive. This confuses pylint, so we have the attribute checking errors in pylint disabled.

Those disabled checks likely would have caught bug 1124756 during continuous integration testing, rather than letting it escape as a regression in 0.17.

The back_populates directive records both sides of the link explicitly, and should allow the relevant pylint checks to be enabled, eliminating the chance of future bugs of that type making it through continuous integration.

Comment 1 Dan Callaghan 2014-11-07 07:28:10 UTC
This patch eliminates all backrefs:

http://gerrit.beaker-project.org/3468

but unfortunately it turns out that is nowhere near enough to fix all pylint attribute checking errors. So it will need more work before we can turn those on.

Comment 6 Dan Callaghan 2015-04-20 02:22:39 UTC
Beaker 20.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.